This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 214876 - USB printer won't print
USB printer won't print
Status: CLOSED DUPLICATE of bug 212290
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: FC6Update
  Show dependency treegraph
 
Reported: 2006-11-09 15:29 EST by Ed Friedman
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-14 11:21:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Printer error log (1.63 KB, application/octet-stream)
2006-11-13 15:35 EST, Ed Friedman
no flags Details

  None (edit)
Description Ed Friedman 2006-11-09 15:29:00 EST
Description of problem:
HP2420D printer connected via USB will not print

Version-Release number of selected component (if applicable):
cups-1.2.5-2.fc6.8  (also seen on cups-1.2.4-9)

How reproducible:
Always

Steps to Reproduce:
1.Set up USB printer with system-config-printer
2.Try to print test page (or try to print any file)
3.
  
Actual results:
Lpq lists printer as ready and printing, but nothing ever prints.

Expected results:
Printer should print.

Additional info:
The printer printed with no problem with FC5.  The kernel is booted with the
noapic flag, since otherwise the computer hangs eventually.  Various web sites
report this same problem by people with other brands of USB printers under FC6
(but before cups-1.2.5-2.fc6.8 was released).
Comment 1 Tim Waugh 2006-11-10 08:13:38 EST
You'll need to give me more information than that.  All the USB printers I'm
using work fine tiwh FC6, and I haven't spotted reports from other people about
USB printers not working on the fedora-* mailing lists.

1. What make and model of printer are you using?
2. How did you configure the printer?
3. What does 'lpstat -s' say?
4. I'd like to see the error_log output from when you print a job, so please do
this (as root):

Stop CUPS:

  /sbin/service cups stop

Clear out the error_log file:

  >/var/log/cups/error_log

Start CUPS again:

  /sbin/service cups start

Then print your job.  When it fails, please attach the /var/log/cups/error_log
file to this bug report.  Thanks.
Comment 2 Ed Friedman 2006-11-13 15:35:39 EST
Created attachment 141097 [details]
Printer error log
Comment 3 Ed Friedman 2006-11-13 16:47:41 EST
1. HP 2420D
2. Using system-config-printer, I selected HP 2420 with Postscript (default) and
used lp as the printer name.
3. device for lp: hp:/usb/hp_LaserJet_2420?serial=CNGJD22636
4. The error_log output is included in the attachment from Comment #2.
Comment 4 Tim Waugh 2006-11-14 11:21:57 EST
D [25/Oct/2006:22:02:16 -0400] [Job 2] %%Creator: Gnome Print Version 2.12.1
D [25/Oct/2006:22:02:16 -0400] [Job 2] %%CreationDate: D:20061025220216

Hmm, this isn't the test page.  Could you please attach that print job if
possible?  This page should help you find out what file it was:

  http://localhost:631/jobs?which_jobs=completed

Please attach the file to bug #212290, which is another instance of this bug.  I
have closed this bug as a duplicate of it.

*** This bug has been marked as a duplicate of 212290 ***

Note You need to log in before you can comment on or make changes to this bug.