Bug 214886 - profile_tick not getting called
profile_tick not getting called
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Rik van Riel
:
Depends On:
Blocks: 215985
  Show dependency treegraph
 
Reported: 2006-11-09 16:15 EST by Frank Ch. Eigler
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: beta2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-22 21:24:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fixes profiling by calling profile_tick from timer interrupt (367 bytes, patch)
2006-11-16 15:35 EST, Rik van Riel
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Sourceware 3279 None None None Never

  None (edit)
Description Frank Ch. Eigler 2006-11-09 16:15:15 EST
Description of problem:
Tools such as systemtap may hook into the profile_tick notifier
mechanism to get told of low-level timer interrupts.  However,
on xen dom0/domU kernels (both fc6 and rhel5), this notifier
function is reportedly never called.

In contrast, the timer_interrupt dom0/domU function is
getting called as expected.

See systemtap bug #3279 for a little more background.
http://sourceware.org/bugzilla/show_bug.cgi?id=3279

We're not sure whether this is intentional.  If so, we'd
appreciate guidance as to what dom0/domU hooks we should use
for hooking into the timer interrupt.
Comment 1 Rik van Riel 2006-11-09 16:22:32 EST
Is this on i686 or x86-64, or both?
Comment 2 Frank Ch. Eigler 2006-11-09 16:27:08 EST
According the systemtap developer, broken on x86-64, works on i386.
Comment 3 Rik van Riel 2006-11-09 17:02:54 EST
Interesting, since the timer_interrupt() code is shared between the two.

This narrows it down quite a bit.  Thank you.
Comment 4 Rik van Riel 2006-11-15 17:28:58 EST
From my reading of the code, it really does look like neither x86-64 or i686
would work with the current code.

Frank, could you confirm that the i386 test really was done with a Xen kernel?

I'm asking this because x86-64 and i686 share the same timer_interrupt()
function, which really only calls other functions that are shared between both
architectures. From timer_interrupt() down, there are no differences between
x86-64 and i686...
Comment 5 Frank Ch. Eigler 2006-11-15 17:57:59 EST
Martin, could you check/confirm that i686-xen does work with timer.profile?
Comment 6 Rik van Riel 2006-11-16 15:35:12 EST
Created attachment 141411 [details]
fixes profiling by calling profile_tick from timer interrupt
Comment 7 Martin Hunt 2006-11-20 09:16:05 EST
(In reply to comment #5)
> Martin, could you check/confirm that i686-xen does work with timer.profile?

No. There was probably some confusion in my initial bug report when I said
timer.profile worked on my 686 machine but not on my x86_64 systems. That turned
out to be because only the x86_64 systems were running xen kernels.

I can confirm that Rik's patch fixes things for me on x86_64.
Comment 8 Jay Turner 2006-11-20 14:57:34 EST
QE ack for RHEL5.
Comment 9 Rik van Riel 2006-11-20 15:00:47 EST
Last week my patch was also merged upstream.
Comment 11 Don Zickus 2006-11-29 17:26:51 EST
in 2.6.18-1.2767.el5
Comment 12 RHEL Product and Program Management 2006-12-22 21:24:37 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.

Note You need to log in before you can comment on or make changes to this bug.