Bug 214897 - storage test fails
storage test fails
Status: CLOSED NOTABUG
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: YangKun
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-09 16:37 EST by Irina Boverman
Modified: 2008-07-16 17:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-01 15:39:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
result rpm (31.11 KB, application/x-rpm)
2006-11-09 16:37 EST, Irina Boverman
no flags Details

  None (edit)
Description Irina Boverman 2006-11-09 16:37:03 EST
Description of problem:
storage test fails
Version-Release number of selected component (if applicable):
hts-5.0-6.noarch.rpm

How reproducible:
always

Steps to Reproduce:
1.install using one disk
2.hts certify -t storage
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Irina Boverman 2006-11-09 16:37:03 EST
Created attachment 140840 [details]
result rpm
Comment 2 YangKun 2006-11-09 21:42:24 EST
there are 2 hard drives in your test machine, and it seems you choosed the
default partitioning method provided by RHEL5, it created a LVM which used both
of the 2 disks. And installed RHEL5 in that LVM(files are spread to 2 disks),
and so, the RHEL5 acctually installed on both 2 disks, not on a single disk,
this violates the
rule(https://hardware.redhat.com/hwcert/doc/s2-rhr2installuse.html):
------------------
Important: to be able to properly test disk storage, Red Hat Enterprise Linux
must be installed on a single disk. There may be any number of extra, unused
disks present in the machine., but the entire install of the operating system
must be confined to a single disk. If Red Hat Enterprise Linux is installed
using more than one disk, some of the disks used for installation will be
unusable for testing. This applies to hardware RAID storage as well as
conventional disks. When installing to a hardware RAID-enabled system, be sure
to put all operating system partitions on the same RAID volume. 
------------------

So please re-install the RHEL5 and make sure the LVM only include 1 disk, leave
the another disk alone. Or you can choose not to use LVM and manually partition
the disk.

The storage test in HTS has the same requirements as the storage test in rhr2.

Comment 3 Irina Boverman 2006-11-10 12:01:51 EST
I verified that OS was installed on one disk only, but during installation I did
not clear second disk, and this is why it looks like it is still in use. Either
we need better insructions for install or we need to improve the test. 
Comment 4 Irina Boverman 2006-12-01 15:39:19 EST
Will review and revise install notes.

Note You need to log in before you can comment on or make changes to this bug.