Bug 214937 - Kernel can't find volume groups (and hence root: panic) on boot of x86_64 md-RAID LVM system after upgrade to kernel 2.6.18
Kernel can't find volume groups (and hence root: panic) on boot of x86_64 md-...
Status: CLOSED DUPLICATE of bug 211030
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-10 00:21 EST by Tom Moertel
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-24 16:11:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the dmesg output for a successful boot under the *previous* kernel, 2.6.17-1.2187_FC5. (25.16 KB, text/plain)
2006-11-10 00:21 EST, Tom Moertel
no flags Details

  None (edit)
Description Tom Moertel 2006-11-10 00:21:11 EST
Description of problem:
Software-RAID (md), LVM-rooted, FC5 x86_64 system panics upon boot after Yum
upgrades kernel to 2.6.18.  It can't find any volume groups.  Photo of panic:

    http://community.moertel.com/~thor/panic.png

If I revert back to the previous kernel, 2.6.17-1.2187_FC5, the system boots no
problem.

Version-Release number of selected component (if applicable):
2.6.18-1.2200.fc5 (x86_64 arch)

How reproducible:
Every time.

Steps to Reproduce:
1. Turn it on.
2. Watch it panic.
3. Take photo.  ;-)
  
Actual results:
Panic shortly after kernel decompresses and starts booting.

Expected results:
Kernel finds volume groups, mounts root, boots happily.

Additional info:
Opteron 165 (dual core) on a Tyan Tomcat K8E mobo, nVidia nFORCE 4 chipset, 4-GB
RAM.

# lspci
00:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a3)
00:01.0 ISA bridge: nVidia Corporation CK804 ISA Bridge (rev a3)
00:01.1 SMBus: nVidia Corporation CK804 SMBus (rev a2)
00:02.0 USB Controller: nVidia Corporation CK804 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation CK804 USB Controller (rev a3)
00:04.0 Multimedia audio controller: nVidia Corporation CK804 AC'97 Audio
Controller (rev a2)
00:06.0 IDE interface: nVidia Corporation CK804 IDE (rev f2)
00:07.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:08.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev a2)
00:0b.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0c.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM
Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
Miscellaneous Control
01:05.0 Display controller: ATI Technologies Inc Rage XL (rev 27)
01:06.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller
(rev 80)
04:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5721 Gigabit
Ethernet PCI Express (rev 11)
05:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce 6600] (rev a2)

# mdadm /dev/md0   # /boot
/dev/md0: 101.88MiB raid1 2 devices, 1 spare. Use mdadm --detail for more detail.

# mdadm /dev/md1   # LVM PV
/dev/md1: 465.57GiB raid5 3 devices, 0 spares. Use mdadm --detail for more detail.

# pvscan
  PV /dev/md1   VG VolGroup00   lvm2 [465.56 GB / 32.00 MB free]
  Total: 1 [465.56 GB] / in use: 1 [465.56 GB] / in no VG: 0 [0   ]

# lvscan
  ACTIVE            '/dev/VolGroup00/LogVol00' [459.53 GB] inherit
  ACTIVE            '/dev/VolGroup00/LogVolSwap' [6.00 GB] inherit


# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
                     466760872 235561348 207106852  54% /
/dev/md0                101018     15766     80036  17% /boot
/dev/shm               1734804         0   1734804   0% /dev/shm


See attachment for dmesg output under *previous* and working-just-fine kernel.
Comment 1 Tom Moertel 2006-11-10 00:21:11 EST
Created attachment 140863 [details]
This is the dmesg output for a successful boot under the *previous* kernel, 2.6.17-1.2187_FC5.
Comment 2 Dave Jones 2006-11-24 16:11:19 EST

*** This bug has been marked as a duplicate of 211030 ***

Note You need to log in before you can comment on or make changes to this bug.