Bug 214943 - scim (immodule) keep clicking after pre-edit word makes gedit crashed
scim (immodule) keep clicking after pre-edit word makes gedit crashed
Status: CLOSED DUPLICATE of bug 213796
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-10 01:59 EST by Caius Chance
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-10 02:49:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Caius Chance 2006-11-10 01:59:49 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. make sure gedit, scim, scim-chewing are installed.
2. Application -> Terminal.
3. input `GTK_IM_MODULE=scim gedit`, gedit launches
4. click on tray icon and select Chinese (Traditional) -> Chewing, in gedit
input field, press 'j' 'i' '3' keys and click「Enter」, still 'j' 'i' '3' keys
and click「Enter」, it should be '我我'
6. select first'我', and press 'c'
8. left click on mouse, the it would crashed

It also occurs in anthy
  
Actual results:
Crashed with BugBuddy screen.

Expected results:
Preedit buffer is cleared.

Additional info:
Please read bug #209575 for traceback and other info.
Comment 1 Jens Petersen 2006-11-10 02:49:12 EST

*** This bug has been marked as a duplicate of 213796 ***

Note You need to log in before you can comment on or make changes to this bug.