Bug 214955 - Chinese input should allow commit with Enter too
Chinese input should allow commit with Enter too
Status: CLOSED DUPLICATE of bug 216100
Product: Fedora
Classification: Fedora
Component: scim-tables (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peng Huang
: FutureFeature, i18n, MoveUpstream, Reopened
: 214957 (view as bug list)
Depends On:
Blocks: 214957 216100 216378
  Show dependency treegraph
 
Reported: 2006-11-10 04:45 EST by Mayank Jain
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-21 03:15:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mayank Jain 2006-11-10 04:45:08 EST
Description of problem:
Unable to commit characters in Chinese simplified (Wubi) when pressing Enter.
However, the same characters are committed using space.

Version-Release number of selected component (if applicable):
scim-tables-chinese-0.5.7-1.fc7
scim-1.4.4-35.fc6

How reproducible:
Everytime when trying to commit chars with "enter"

Steps to Reproduce:
1. Open gedit, select simplified chinese > wubi
2. press "l" & press "enter"
3. "l" is committed to gedit. Instead its chinese representation (国) should
have been comitted.
  
Actual results:
l

Expected results:
国

Additional info:
Comment 1 Mitch Davis 2006-11-11 03:12:01 EST
This happens for pinyin entry method too.

I keep expecting Enter to work, since it does with the Windows IME.
Comment 2 Caius Chance 2006-11-12 20:24:06 EST
FYI in Changjie, Space is used to be the commit Key.

I am not sure if there would be appropriate to trigger a feature request to
customize the commit key for scim-tables, or scim-tables-chinese.
Comment 3 Jens Petersen 2006-11-12 20:41:19 EST
Using space for commit is pretty standard for Chinese: I think it is
a matter of habit... :)

You could try requestinging upstream to have the commit keys be made configurable.
For scim-tables if you really want to override Space you can copy the table .txt to
your personal scim folder and change the commit key in the table file and recompile
the table with scim-make-table.
Comment 4 Jens Petersen 2006-11-12 20:42:22 EST
*** Bug 214957 has been marked as a duplicate of this bug. ***
Comment 5 Mitch Davis 2006-11-12 22:00:24 EST
This is not about overriding Space as I don't want to change Space's function. 
I'm talking about what Enter does.

I'm proposing that Enter does a commit in addition to space, because the present
behaviour of Enter is not useful to anyone and violates the Principle of Least
Surprise.
Comment 6 Jens Petersen 2006-11-17 04:21:00 EST
Shawn, what do you think about this?
Comment 7 Peng Huang 2006-11-17 04:48:41 EST
I think most Chinese just use [space] as a commit key, however I went through
the table.txt, it has a value COMMINT_KEYS. It can specify more than one keys.
If one user want to add a new commit key, he can recreate it by self.
Comment 8 Mitch Davis 2006-11-17 07:14:47 EST
I searched every file of every scim-related package on my machine for COMMINT_KEYS:

rpm -q -a | grep scim
scim-tables-chinese-0.5.6-3.2.fc5
scim-pinyin-0.5.91-4.5.fc5
scim-1.4.4-9.8.fc5
scim-libs-1.4.4-9.8.fc5
scim-tables-0.5.6-3.2.fc5

for pkg in $(rpm -q -a | grep scim); do
  rpm -q -l $pkg | grep COMMINT_KEYS | sed -e "s/^/$w: /g"
done

No matches :-(

I also tried searching for "COMMIT_KEYS".

Can you point me to where I can find more info?

Thank you.

(Still being driven crazy by Enter not being useful)
Comment 9 Peng Huang 2006-11-19 20:43:28 EST
Sorry! It should be COMMIT_KEYS. It is not included in the binary rpm files.
It's included in src.rpm. If you want to change the COMMIT_KEYS, you should get
a source of scim-tables-chinese-*.rpm. It includes wubi input tables. In the
table, you will find COMMIT_KEYS. The table will be translate to a binary table
when build. You should change COMMIT_KEYS's value and rebuild it. BTW, the
[Return] key have been defined as FORWARD_KEYS in wubi table, you should change
it too.

Comment 10 Peng Huang 2006-11-21 03:15:20 EST

*** This bug has been marked as a duplicate of 216100 ***

Note You need to log in before you can comment on or make changes to this bug.