Bug 214970 - update agg to 2.5
update agg to 2.5
Product: Fedora
Classification: Fedora
Component: agg (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Depends On:
  Show dependency treegraph
Reported: 2006-11-10 06:44 EST by Patrice Dumas
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-01-06 11:52:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Patrice Dumas 2006-11-10 06:44:46 EST
Description of problem:

agg 2.5 is released. It includes a licence change which shouldn't
affect fedora (it is now gpl). Beware that the link on the
download page points to 2.4, but 2.5 seems to ba available at

It also seems that the agg author updates tarballs without 
changing the name, so that the 2.4 version in fedora isn't
the 2.4 version available on the web site...

Anyway I need the 2.5 (or updated 2.4 version) version for agg 
support in gnash, which may be interesting for next gnash
release (although it is not certain that I'll use it).

It is a request for enhancement.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Caolan McNamara 2006-11-10 07:18:15 EST
I'll rebuild with the new 2.4 sources for devel for the moment, this 2.5 GPL
license change may be a problem, OOo currently links to it but is LGPL itself
linking to a GPL only lib would compromise that. On the other hand we don't need
agg for 2.1.X anymore.

I believe KDE is the other possible consumer of agg, we might be able to bump to
the GPL agg if KDE isn't using it, or depending on where it fits into that
world, then disable OOo's usage of it and possibly move it to extras in that case.

than: Does anything in KDE use libagg ?
Comment 2 Ngo Than 2006-11-10 09:56:15 EST
Caolan, it's not used in current KDE3
Comment 3 Fabio Pedretti 2006-12-06 05:53:27 EST
I agree that would be nice if an updated package with current agg-2.4 would be
provided in FC6, to make building gnash possible.
Comment 4 Caolan McNamara 2007-01-06 11:52:35 EST
rawhide bumped to 2.5, an update for FC-6 to bump the 2.4 to the replacement 2.4
upstream tarball will be pushed as 2.4-2.2.

Note You need to log in before you can comment on or make changes to this bug.