Bug 214971 - 0x200C (ZWNJ) is needed in Inscript keymap (ml_IN)
0x200C (ZWNJ) is needed in Inscript keymap (ml_IN)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: m17n-db (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mayank Jain
: i18n
Depends On:
Blocks: 214975
  Show dependency treegraph
 
Reported: 2006-11-10 06:55 EST by Ani Peter
Modified: 2016-07-31 21:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-15 07:59:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ani Peter 2006-11-10 06:55:11 EST
Description of problem:
0X200C (Zero Width non-Joiner) is not present in the keyboard.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Mayank Jain 2006-11-10 07:14:19 EST
Hi Ani,

Kindly furnish the following details

- Steps to Reproduce:
- Actual results:
- Expected results:
- Which character the ZWNJ be mapped to

If ZWNJ is not present in the TDIL ml_IN inscript keyboard layout, can you
please submit an updated key summary in this bug. This is important as users
will know that how to input a ZWNJ.

Also, do you need a Halant with ZWNJ?

Please be specific & detailed when filing a bug report.
Thanks,
Mayank
Comment 2 Ani Peter 2006-11-10 07:48:28 EST
Mayank,

In Malayalam we have certain conjuncts which are to be used combined in some
words and in some cases according to the key sequence.

Take example the combination,
Any consonant, say X (except 0D35) + 0D4D + 0D35 = the result X with a sign on
the right side. 
ie, സ + ് + വ = സ്വ - (i)
But in some case they are not needed to be joined and want the result as 
ie, സ + ് + വ = സ്‍വ (ii)

For the (ii) we need to use a ZWNJ which is missing in the Malayalam Inscript
keyboard.

Steps to reproduce:

(i)Open kedit and select Malayalam
(ii)Type key 'm'
(iii)Type key 'd'
(iv)Select Raw Hide and type 200C
(iv)Type key 'b'

Actual results:

Since 200C is not present, we use 200D (ZWJ) and hence cursor positions become
wrong. Also logically the use of 200D is also wrong as its purpose is to join
and thus the need of 200C is essential.

Expected Result:


(i)Open kedit and select Malayalam
(ii)Type key 'm'
(iii)Type key 'd'
(iv)Use 200C
(iv)Type key 'b'

The result must be സ്‍വ

The key to which 200C (ZWNJ) is to be mapped is key '\'.

Please ask if questions.

Thanks
Ani
Comment 3 Mayank Jain 2006-11-13 02:12:20 EST
Fixed in

Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
m17n-db-1.3.3-37.fc7                      dist-fc7              majain
m17n-db-1.3.3-35.fc6                      dist-fc6-updates-candidate  majain

with an updated key summary.

Thanks,
Mayank
Comment 4 A S Alam 2007-03-15 07:59:46 EDT
ZWCJ is added to keyboard
bug is fixed, tested with following Package:
m17n-db-1.3.4-7.fc7

Note You need to log in before you can comment on or make changes to this bug.