Bug 2150017 - dpkg-1.21.20 is available
Summary: dpkg-1.21.20 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dpkg
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sergio Basto
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-12-01 15:56 UTC by Upstream Release Monitoring
Modified: 2023-03-01 03:09 UTC (History)
3 users (show)

Fixed In Version: dpkg-1.21.20-2.fc37 dpkg-1.21.20-2.el9 dpkg-1.21.20-2.fc36
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-02-24 04:45:17 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
Update to 1.21.10 (#2150017) (1006 bytes, patch)
2022-12-01 15:56 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 1.21.11 (#2150017) (1006 bytes, patch)
2022-12-03 04:28 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 1.21.12 (#2150017) (1006 bytes, patch)
2022-12-06 10:18 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 1.21.13 (#2150017) (1007 bytes, patch)
2022-12-20 05:02 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 1.21.14 (#2150017) (1006 bytes, patch)
2023-01-02 03:50 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 1.21.15 (#2150017) (1006 bytes, patch)
2023-01-02 17:33 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 1.21.16 (#2150017) (1006 bytes, patch)
2023-01-05 05:09 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 1.21.18 (#2150017) (1007 bytes, patch)
2023-01-10 21:56 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 1.21.19 (#2150017) (1.11 KB, patch)
2023-01-26 02:57 UTC, Upstream Release Monitoring
no flags Details | Diff

Description Upstream Release Monitoring 2022-12-01 15:56:29 UTC
Releases retrieved: 1.21.10
Upstream release that is considered latest: 1.21.10
Current version/release in rawhide: 1.21.9-1.fc37
URL: https://tracker.debian.org/pkg/dpkg

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/8127/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/dpkg

Comment 1 Upstream Release Monitoring 2022-12-01 15:56:35 UTC
Created attachment 1929079 [details]
Update to 1.21.10 (#2150017)

Comment 2 Upstream Release Monitoring 2022-12-01 16:06:40 UTC
the-new-hotness/release-monitoring.org's scratch build of dpkg-1.21.10-1.fc36.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=94793579

Comment 3 Upstream Release Monitoring 2022-12-03 04:28:07 UTC
Releases retrieved: 1.21.11
Upstream release that is considered latest: 1.21.11
Current version/release in rawhide: 1.21.9-1.fc37
URL: https://tracker.debian.org/pkg/dpkg

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/8127/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/dpkg

Comment 4 Upstream Release Monitoring 2022-12-03 04:28:12 UTC
Created attachment 1929585 [details]
Update to 1.21.11 (#2150017)

Comment 5 Upstream Release Monitoring 2022-12-03 04:37:29 UTC
the-new-hotness/release-monitoring.org's scratch build of dpkg-1.21.11-1.fc36.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=94863518

Comment 6 Upstream Release Monitoring 2022-12-06 10:18:36 UTC
Releases retrieved: 1.21.12
Upstream release that is considered latest: 1.21.12
Current version/release in rawhide: 1.21.9-1.fc37
URL: https://tracker.debian.org/pkg/dpkg

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/8127/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/dpkg

Comment 7 Upstream Release Monitoring 2022-12-06 10:18:40 UTC
Created attachment 1930422 [details]
Update to 1.21.12 (#2150017)

Comment 8 Upstream Release Monitoring 2022-12-06 10:31:39 UTC
the-new-hotness/release-monitoring.org's scratch build of dpkg-1.21.12-1.fc36.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=95007648

Comment 9 Upstream Release Monitoring 2022-12-20 05:02:25 UTC
Releases retrieved: 1.21.13
Upstream release that is considered latest: 1.21.13
Current version/release in rawhide: 1.21.9-1.fc37
URL: https://tracker.debian.org/pkg/dpkg

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/8127/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/dpkg

Comment 10 Upstream Release Monitoring 2022-12-20 05:02:33 UTC
Created attachment 1933704 [details]
Update to 1.21.13 (#2150017)

Comment 11 Upstream Release Monitoring 2022-12-20 05:08:17 UTC
the-new-hotness/release-monitoring.org's scratch build of dpkg-1.21.13-1.fc36.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=95556643

Comment 12 Upstream Release Monitoring 2023-01-02 03:50:01 UTC
Releases retrieved: 1.21.14
Upstream release that is considered latest: 1.21.14
Current version/release in rawhide: 1.21.9-1.fc37
URL: https://tracker.debian.org/pkg/dpkg

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/8127/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/dpkg

Comment 13 Upstream Release Monitoring 2023-01-02 03:50:11 UTC
Created attachment 1935266 [details]
Update to 1.21.14 (#2150017)

Comment 14 Upstream Release Monitoring 2023-01-02 03:55:21 UTC
the-new-hotness/release-monitoring.org's scratch build of dpkg-1.21.14-1.fc36.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=95716498

Comment 15 Upstream Release Monitoring 2023-01-02 17:33:52 UTC
Releases retrieved: 1.21.15
Upstream release that is considered latest: 1.21.15
Current version/release in rawhide: 1.21.9-1.fc37
URL: https://tracker.debian.org/pkg/dpkg

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/8127/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/dpkg

Comment 16 Upstream Release Monitoring 2023-01-02 17:33:57 UTC
Created attachment 1935353 [details]
Update to 1.21.15 (#2150017)

Comment 17 Upstream Release Monitoring 2023-01-02 17:39:01 UTC
the-new-hotness/release-monitoring.org's scratch build of dpkg-1.21.15-1.fc36.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=95724932

Comment 18 Upstream Release Monitoring 2023-01-05 05:09:27 UTC
Releases retrieved: 1.21.16
Upstream release that is considered latest: 1.21.16
Current version/release in rawhide: 1.21.9-1.fc37
URL: https://tracker.debian.org/pkg/dpkg

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/8127/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/dpkg

Comment 19 Upstream Release Monitoring 2023-01-05 05:09:32 UTC
Created attachment 1935845 [details]
Update to 1.21.16 (#2150017)

Comment 20 Upstream Release Monitoring 2023-01-05 05:15:07 UTC
the-new-hotness/release-monitoring.org's scratch build of dpkg-1.21.16-1.fc36.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=95772642

Comment 21 Upstream Release Monitoring 2023-01-05 14:56:00 UTC
Releases retrieved: 1.21.17
Upstream release that is considered latest: 1.21.17
Current version/release in rawhide: 1.21.9-1.fc37
URL: https://tracker.debian.org/pkg/dpkg

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/8127/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/dpkg

Comment 22 Upstream Release Monitoring 2023-01-05 14:56:04 UTC
Scratch build failed. Details below:

BuilderException: Build failed:
Command '['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', '/var/tmp/thn-wsvfb1ci/dpkg.spec']' returned non-zero exit status 1.

StdOut:
error: Bad source: ./dpkg_1.21.17.tar.xz: No such file or directory


Traceback:
  File "/usr/local/lib/python3.10/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 188, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 23 Upstream Release Monitoring 2023-01-10 21:56:00 UTC
Releases retrieved: 1.21.18
Upstream release that is considered latest: 1.21.18
Current version/release in rawhide: 1.21.9-1.fc37
URL: https://tracker.debian.org/pkg/dpkg

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/8127/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/dpkg

Comment 24 Upstream Release Monitoring 2023-01-10 21:56:04 UTC
Created attachment 1937185 [details]
Update to 1.21.18 (#2150017)

Comment 25 Upstream Release Monitoring 2023-01-10 22:01:44 UTC
the-new-hotness/release-monitoring.org's scratch build of dpkg-1.21.18-1.fc36.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=95983273

Comment 26 Upstream Release Monitoring 2023-01-26 02:57:54 UTC
Releases retrieved: 1.21.19
Upstream release that is considered latest: 1.21.19
Current version/release in rawhide: 1.21.9-2.fc38
URL: https://tracker.debian.org/pkg/dpkg

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/8127/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/dpkg

Comment 27 Upstream Release Monitoring 2023-01-26 02:57:58 UTC
Created attachment 1940530 [details]
Update to 1.21.19 (#2150017)

Comment 28 Upstream Release Monitoring 2023-01-26 03:08:23 UTC
the-new-hotness/release-monitoring.org's scratch build of dpkg-1.21.19-1.fc36.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=96691116

Comment 29 Upstream Release Monitoring 2023-02-07 15:12:36 UTC
Releases retrieved: 1.21.20
Upstream release that is considered latest: 1.21.20
Current version/release in rawhide: 1.21.9-2.fc38
URL: https://tracker.debian.org/pkg/dpkg

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/8127/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/dpkg

Comment 30 Upstream Release Monitoring 2023-02-07 15:12:40 UTC
Scratch build failed. Details below:

GenericError: Invalid method: krb_login
Traceback:
  File "/usr/local/lib/python3.10/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 195, in build
    session = self._session_maker()
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 422, in _session_maker
    result = koji_session.krb_login(
  File "/usr/lib/python3.10/site-packages/koji/__init__.py", line 2362, in __call__
    return self.__func(self.__name, args, opts)
  File "/usr/lib/python3.10/site-packages/koji/__init__.py", line 2874, in _callMethod
    raise err

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 31 Fedora Update System 2023-02-17 10:19:27 UTC
FEDORA-2023-44e5069fcf has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2023-44e5069fcf

Comment 32 Fedora Update System 2023-02-17 10:19:48 UTC
FEDORA-2023-f1cea7ab24 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2023-f1cea7ab24

Comment 33 Fedora Update System 2023-02-17 10:20:14 UTC
FEDORA-EPEL-2023-5d0556ffe4 has been submitted as an update to Fedora EPEL 9. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2023-5d0556ffe4

Comment 34 Fedora Update System 2023-02-18 01:26:25 UTC
FEDORA-EPEL-2023-5d0556ffe4 has been pushed to the Fedora EPEL 9 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2023-5d0556ffe4

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 35 Fedora Update System 2023-02-18 02:21:24 UTC
FEDORA-2023-f1cea7ab24 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-f1cea7ab24`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-f1cea7ab24

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 36 Fedora Update System 2023-02-18 02:37:07 UTC
FEDORA-2023-44e5069fcf has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-44e5069fcf`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-44e5069fcf

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 37 Fedora Update System 2023-02-21 01:23:05 UTC
FEDORA-2023-44e5069fcf has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-44e5069fcf`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-44e5069fcf

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 38 Fedora Update System 2023-02-21 01:53:26 UTC
FEDORA-EPEL-2023-5d0556ffe4 has been pushed to the Fedora EPEL 9 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2023-5d0556ffe4

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 39 Fedora Update System 2023-02-21 02:19:44 UTC
FEDORA-2023-f1cea7ab24 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-f1cea7ab24`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-f1cea7ab24

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 40 Fedora Update System 2023-02-24 04:45:17 UTC
FEDORA-2023-44e5069fcf has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 41 Fedora Update System 2023-03-01 02:55:37 UTC
FEDORA-EPEL-2023-5d0556ffe4 has been pushed to the Fedora EPEL 9 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 42 Fedora Update System 2023-03-01 03:09:40 UTC
FEDORA-2023-f1cea7ab24 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.