Bug 215004 - rpm creates a .rpmsave file, but no updated file
rpm creates a .rpmsave file, but no updated file
Status: CLOSED DUPLICATE of bug 214865
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-10 10:55 EST by Jay Fenlason
Modified: 2014-08-31 19:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-10 11:02:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jay Fenlason 2006-11-10 10:55:27 EST
Description of problem: 
On my rawhide box, I built a new rpm of xinetd (new upstream release) and 
installed it for some unit testing.  Here's a cut-n-paste of my terminal 
session: 
[root@fenlason-rhide devel]# rpm -Fv i386/rsync-2.6.9-2.i386.rpm  
Preparing packages for installation... 
warning: /etc/xinetd.d/rsync saved as /etc/xinetd.d/rsync.rpmsave 
rsync-2.6.9-2 
[root@fenlason-rhide devel]# cd /etc/xinetd.d 
[root@fenlason-rhide xinetd.d]# ls 
amanda          cvs             echo-stream   kshell         swat 
amandaidx       daytime-dgram   eklogin       ktalk          tcpmux-server 
amidxtape       daytime-stream  ekrb5-telnet  rexec          telnet 
chargen-dgram   discard-dgram   gssftp        rlogin         tftp 
chargen-stream  discard-stream  klogin        rsh            time-dgram 
cups-lpd        echo-dgram      krb5-telnet   rsync.rpmsave  time-stream 
[root@fenlason-rhide xinetd.d]# cd /local/home/hack/rsync/devel 
[root@fenlason-rhide devel]# rpm2cpio < i386/rsync-2.6.9-2.i386.rpm | cpio -t 
./etc/xinetd.d/rsync 
./usr/bin/rsync 
... 
 
Note that /etc/xinetd.d/rsync is in the rpm, but after the upgrade it is 
missing from /etc/xinetd.d 
 
Version-Release number of selected component (if applicable): 
rpm-4.4.2-35.fc7 
 
How reproducible: 
Sometimes 
 
Steps to Reproduce: 
1. 
2. 
3. 
   
Actual results: 
As described above 
 
Expected results: 
All files included in the rpm get installed 
 
Additional info: 
I believe this bug may be responsible for my mysteriously missing /etc/inittab 
the other day too.
Comment 1 Paul Nasrat 2006-11-10 11:02:23 EST

*** This bug has been marked as a duplicate of 214865 ***

Note You need to log in before you can comment on or make changes to this bug.