Bug 215027 - gnome-settings-daemon unaligned accesses
gnome-settings-daemon unaligned accesses
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: control-center (Show other bugs)
5.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
David Lawrence
: Desktop, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-10 12:39 EST by Bastien Nocera
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version: beta2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-04 14:08:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 392853 None None None Never

  None (edit)
Description Bastien Nocera 2006-11-10 12:39:31 EST
control-center-2.16.0-11.el5

Nov 10 15:38:24 localhost kernel: gnome-settings-(3913): unaligned access to
0x60000ffffe1fb42c, ip=0x2000000001d2add0

The keyboard code strikes again! Adding a prctl() at the start of the code is
probably the easiest to avoid insanity.

Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "ia64-redhat-linux-gnu"...
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".

(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 2305843009259911824 (LWP 5158)]
[New Thread 2305843009331261968 (LWP 5164)]

Program received signal SIGBUS, Bus error.
[Switching to Thread 2305843009259911824 (LWP 5158)]
_XData32 (dpy=0x600000000003c800, data=0x60000fffffc234cc, len=0)
   at XlibInt.c:3056
3056                *buf++ = *data++;
#0  _XData32 (dpy=0x600000000003c800, data=0x60000fffffc234cc, len=0)
   at XlibInt.c:3056
#1  0x2000000001cbb5f0 in XChangeProperty (dpy=0x600000000003c800, w=40,
   property=267, type=19, format=32, mode=0, data=0x60000fffffc234cc "",
   nelements=<value optimized out>) at ChProp.c:85
#2  0x2000000000194770 in xkl_engine_set_switch_to_secondary_group (
   engine=<value optimized out>, val=0) at xklavier.c:71
#3  0x2000000000194b60 in xkl_engine_constructor (type=<value optimized out>,
   n_construct_properties=<value optimized out>,
   construct_properties=<value optimized out>) at xklavier.c:627
#4  0x2000000001a3fac0 in g_object_newv () from /lib/libgobject-2.0.so.0
#5  0x2000000001a41450 in g_object_new_valist () from /lib/libgobject-2.0.so.0
#6  0x2000000001a41710 in g_object_new () from /lib/libgobject-2.0.so.0
#7  0x2000000000194520 in xkl_engine_get_instance (display=0x600000000003c800)
   at xklavier.c:194
#8  0x40000000000193c0 in ?? ()
3051                i = len;
3052            dpy->bufptr = (char *)buf + i;
3053            len -= i;
3054            i >>= 2;
3055            while (--i >= 0)
3056                *buf++ = *data++;
3057        }
3058        return 0;
3059    }
3060    #endif /* LONG64 */
#2  0x2000000000194770 in xkl_engine_set_switch_to_secondary_group (
   engine=<value optimized out>, val=0) at xklavier.c:71
71              XChangeProperty(dpy,
66      static void
67      xkl_engine_set_switch_to_secondary_group(XklEngine * engine, gboolean val)
68      {
69              CARD32 propval = (CARD32) val;
70              Display *dpy = xkl_engine_get_display(engine);
71              XChangeProperty(dpy,
72                              xkl_engine_priv(engine, root_window),
73                              xkl_engine_priv(engine,
74                                              atoms)[XKLAVIER_ALLOW_SECONDARY],
75                              XA_INTEGER, 32, PropModeReplace,
Comment 1 RHEL Product and Program Management 2006-11-10 13:01:00 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Ray Strode [halfline] 2006-11-10 14:36:58 EST
ah this looks like the age-old XChangeProperty has the weirdest semantics ever bug.

I think the CARD32 is supposed to be a long there.  (even on platforms where
long isn't 32-bit)
Comment 3 Ray Strode [halfline] 2006-11-10 14:44:09 EST
Hey, i've built libxklavier-3.0-3.el5 with the change mentioned in comment 2. 
Can you give it a whirl (i don't have access to an ia64 machine).  If it works,
we should push this upstream.
Comment 4 RHEL Product and Program Management 2006-12-22 21:30:33 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.
Comment 5 Ray Strode [halfline] 2006-12-22 21:51:44 EST
Bastien
Comment 6 Ray Strode [halfline] 2006-12-22 21:54:13 EST
oops, ignore comment 5.

I'm reopening this bug because I want to make sure the fix fixed the problem. 
It was never verified by Bastien or QA.

(If it is verified, then I want to get the fix upstream)

Bastien, can you confirm?
Comment 8 Bastien Nocera 2007-01-03 09:49:27 EST
I don't have an updated RHEL5 ia64 machine at hand, so I can't verify the fix.

Note You need to log in before you can comment on or make changes to this bug.