Bug 215029 - Xine-lib will not play .shn audio files
Xine-lib will not play .shn audio files
Product: Fedora
Classification: Fedora
Component: xine-lib (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2006-11-10 12:55 EST by Jeff Rasmussen
Modified: 2008-05-06 12:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-06 12:46:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jeff Rasmussen 2006-11-10 12:55:50 EST
Description of problem:
Xine-lib will not play .shn audio files

Version-Release number of selected component (if applicable):

How reproducible:
always, with any program that references xine-lib
Comment 1 Aurelien Bompard 2006-11-11 05:10:43 EST
Please try this update :
and tell me if it's playing your Shorten files.
Comment 2 Ville Skyttä 2006-11-11 05:32:46 EST
Aurelien, do you have a SRPM somewhere for review?

Note this: http://etree.org/shncom.html
"The Shorten source code is the property of SoftSound Limited and has been made
available to the general public for non-commercial use."

If xine-lib uses/includes that code, it is not acceptable in Fedora Extras
("non-commercial").  If it uses another implementation, then I don't know, as I
can't find out whether shn as a *format* is free or not.  Please check this
before including it in FE.
Comment 3 Aurelien Bompard 2006-11-11 07:21:58 EST
I merely added a fix from xine-lib cvs :
--- src/demuxers/demux_shn.c 2005/07/17 21:49:58
+++ src/demuxers/demux_shn.c 2006/09/28 22:27:52 1.2
@@ -114,6 +114,9 @@

   this->status = DEMUX_OK;

+  _x_stream_info_set(this->stream, XINE_STREAM_INFO_HAS_VIDEO, 0);
+  _x_stream_info_set(this->stream, XINE_STREAM_INFO_HAS_AUDIO, 1);
   /* send start buffers */

References :

I will not add a new plugin to xine-lib in Extras without seeking legal advice.
But since shn is already enabled in FE xine-lib and looks non-free, I'll remove
it (add it to the cleaned up sources in xine-lib-cleanup-sources.sh)
Comment 4 Jeff Rasmussen 2006-11-11 09:58:49 EST
Aurelien, I tried the update and the Shorten files are playing fine.  Thanks for
the fix.
Comment 5 Aurelien Bompard 2006-11-13 13:49:47 EST
Tom, I've looked at the only file referencing shn files in the xine-lib sources
(src/demuxers/demux_shn.c), and it looks really small. I don't think xine-lib
contains the shorten decoding code, but since I'm no C coder I'd like someone
else's advice on the matter. What's your opinion ?
Comment 6 Bastien Nocera 2007-02-21 11:12:07 EST
AFAIK, it's just the demuxer, the ffmpeg plugin takes care of the decoding.
Comment 7 Jeff Rasmussen 2007-05-07 18:52:41 EDT
I think the problem now lies elsewhere (maybe ffmpeg?) because the shn demuxing
problem has been solved since xine-lib 1.1.3 (and of course with Aurelien's
patch to 1.1.2), and I can't get any shn files to play with either Xine or
Comment 8 Jeff Rasmussen 2007-06-27 11:12:17 EDT
Just a quick FYI - My shn files are once again playing without a hitch both on
xine-lib and gstreamer based apps.  I'm running Fedora 7 now.  Not quite sure
what changed, but I certainly am happy that they're working once again.
Comment 9 Bug Zapper 2008-04-04 00:35:16 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 10 Bug Zapper 2008-05-06 12:46:24 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.