Bug 215098 - No wine as non-root
No wine as non-root
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
http://forums.fedoraforum.org/showthr...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-10 17:06 EST by Daniel Hauck
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-20 05:23:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sample runs from terminal (7.52 KB, text/plain)
2006-11-14 03:23 EST, Daniel Hauck
no flags Details
similar attempts at winecfg (2.07 KB, text/plain)
2006-11-14 03:32 EST, Daniel Hauck
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 1182 None None None Never

  None (edit)
Description Daniel Hauck 2006-11-10 17:06:38 EST
Description of problem:
Running most Wine apps as non-root user results in wine failure.  Running same
as root works.  Example: run "winecfg" as non-root user then after waiting
longer than you should, look at the running processes (using ps ax).  Kill those
processes and run "sudo winecfg" and it snaps right up on the screen
immediately.  The same example applies to ies4linux and others.

Version-Release number of selected component (if applicable):
(Current since initial release)

How reproducible:
Consistant every time

Steps to Reproduce:
1. run winecfg
2. ...wait...
3. run winecfg as root
  
Actual results:
winecfg will not run as a non-root user

Expected results:
winecfg should run as a normal user

Additional info:
Comment 1 Andreas Bierfert 2006-11-11 04:29:38 EST
I can not at all reproduce this. Please move your ~/.wine folder to ~/.wine-old
and retry and make sure your user is allowed to write to ~/. If that does not
work please add more details to this bug.
Comment 2 Daniel Hauck 2006-11-14 03:23:47 EST
Created attachment 141135 [details]
sample runs from terminal
Comment 3 Daniel Hauck 2006-11-14 03:32:09 EST
Created attachment 141137 [details]
similar attempts at winecfg
Comment 4 Daniel Hauck 2006-11-14 03:36:54 EST
The two sample runs seem to indicate that wine cannot communicate with the x11
stuff (whatever that means exactly, I'm unsure.)  Perhaps there's some X.org
setting that is blocking users from running stuff that root can otherwise run?

I started having this problem late in my use of FC5 and immediately in FC6. 
Before whatever had changed in FC5, I was running both of these just fine under
wine.  I am unsure what update had occured to trigger this problem under FC5
which is unfortunate.  I am hopeful the logs provided will give some ideas as to
what has gone wrong and what I can do to fix it.
Comment 5 Andreas Bierfert 2006-11-14 07:26:58 EST
You are not using scim input by any chance are you?
Comment 6 paul 2006-11-19 08:54:49 EST
(In reply to comment #5)
> You are not using scim input by any chance are you?

I also note that Wine stop working after installation some while, and
incidentally should be after I installed Chinese Support w/ SCIM.

After uninstalling SCIM, it works again !?
Comment 7 Daniel Hauck 2006-11-19 10:17:56 EST
http://forums.fedoraforum.org/showthread.php?t=127383&goto=newpost

This forum thread contains a description of the problem and proposed patch code
to SCIM.

I don't pretend to understand what's going on there, but even with SCIM enabled,
I can run Wine apps as root.  If a fix for SCIM resolves the problem, though, so
be it.
Comment 8 Andreas Bierfert 2006-11-20 05:23:15 EST
This is a complete wrong statement in the forum. As pointed out in another
bugreport (#212782) an by the wine folks: The error is not in wine. Closing as
freedesktop.org upstream.

Note You need to log in before you can comment on or make changes to this bug.