Bug 215135 - sealert does not start (traceback)
Summary: sealert does not start (traceback)
Keywords:
Status: CLOSED DUPLICATE of bug 214218
Alias: None
Product: Fedora
Classification: Fedora
Component: setroubleshoot
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John Dennis
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-11 10:08 UTC by Aurelien Bompard
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-11-11 13:29:25 UTC


Attachments (Terms of Use)

Description Aurelien Bompard 2006-11-11 10:08:39 UTC
Description of problem:
sealert crashes on startup :
$ sealert
Introspect error: Message did not receive a reply (timeout by message bus)

(Navigateur setroubleshoot:11512): libglade-CRITICAL **:
glade_xml_build_interface: assertion `wid != NULL' failed
Traceback (most recent call last):
  File "/usr/bin/sealert", line 438, in ?
    start_service()
  File "/usr/bin/sealert", line 376, in start_service
    app.main()
  File "/usr/bin/sealert", line 350, in main
    self.browser = BrowserApplet()
  File "/usr/lib/python2.4/site-packages/setroubleshoot/browser.py", line 79, in
__init__
    self.init_widgets()
  File "/usr/lib/python2.4/site-packages/setroubleshoot/browser.py", line 104,
in init_widgets
    self.window.connect_after("realize", self.on_realize)
AttributeError: 'NoneType' object has no attribute 'connect_after'


Version-Release number of selected component (if applicable):
setroubleshoot-1.0-1

How reproducible:
Always

Additional info:
setroubleshootd is running:
$ pgrep -l setroubleshootd
23772 setroubleshootd

DBus is running:
$ ps axf | grep dbus
 2154 ?        Ssl    0:00 dbus-daemon --system
 3393 ?        Ss     0:00              \_ /usr/bin/ssh-agent
/usr/bin/dbus-launch --exit-with-session /home/gauret/.xsession
 3396 ?        Ssl    0:00 /bin/dbus-daemon --fork --print-pid 8 --print-address
6 --session
 3397 ?        S      0:00 /usr/bin/dbus-launch --exit-with-session
/home/gauret/.xsession

I'm running KDE.

Comment 1 John Dennis 2006-11-11 13:29:25 UTC
Given you're in France I'm reasonably sure this is a duplicate of bug #214218,
an i18n name was being used incorrectly. You can find a workaround listed there
until a new package is posted. If that is not the issue, please feel free to
reopen the bug.

*** This bug has been marked as a duplicate of 214218 ***


Note You need to log in before you can comment on or make changes to this bug.