Bug 215156 - BUG: sleeping function called from invalid context at kernel/rwsem.c:20
BUG: sleeping function called from invalid context at kernel/rwsem.c:20
Status: CLOSED DUPLICATE of bug 201508
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-11 12:28 EST by Ronald Warsow
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-21 17:44:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronald Warsow 2006-11-11 12:28:37 EST
Description of problem:
wakeup from hibernate gives:
swsusp: Restoring Highmem
BUG: sleeping function called from invalid context at kernel/rwsem.c:20
in_atomic():0, irqs_disabled():1
 [<c04051db>] dump_trace+0x69/0x1af
 [<c0405339>] show_trace_log_lvl+0x18/0x2c
 [<c04058ed>] show_trace+0xf/0x11
 [<c04059ea>] dump_stack+0x15/0x17
 [<c0439446>] down_read+0x12/0x20
 [<c0431601>] blocking_notifier_call_chain+0xe/0x29
 [<c05a9798>] cpufreq_resume+0x118/0x135
 [<c0551440>] __sysdev_resume+0x20/0x53
 [<c0551583>] sysdev_resume+0x16/0x47
 [<c0555767>] device_power_up+0x5/0xa
 [<c0442360>] swsusp_suspend+0x74/0x90
 [<c04427f6>] pm_suspend_disk+0x43/0xc9
 [<c0441959>] enter_state+0x53/0x176
 [<c0441b01>] state_store+0x85/0x99
 [<c04a5fe6>] subsys_attr_store+0x1e/0x22
 [<c04a60d9>] sysfs_write_file+0xa7/0xce
 [<c046f805>] vfs_write+0xa8/0x159
 [<c046fe32>] sys_write+0x41/0x67
 [<c0404013>] syscall_call+0x7/0xb
DWARF2 unwinder stuck at syscall_call+0x7/0xb
Leftover inexact backtrace:
 =======================
PCI: Enabling device 0000:00:1d.0 (0000 -> 0001)


Version-Release number of selected component (if applicable):

kernel-2.6.18-1.2798.fc6
How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
see above

Expected results:


Additional info:
Comment 1 Dan Carpenter 2006-11-12 19:19:00 EST
This is the same as bug 201508

sysdev_resume() is called with interrupts off according to the comments.
Comment 2 Nigel Cunningham 2006-12-21 17:44:08 EST

*** This bug has been marked as a duplicate of 201508 ***

Note You need to log in before you can comment on or make changes to this bug.