Bug 215159 - No such file or directory in /usr/share/phpMyAdmin/changelog.php on line 9
No such file or directory in /usr/share/phpMyAdmin/changelog.php on line 9
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: phpMyAdmin (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-11 12:47 EST by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-15 09:59:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2006-11-11 12:47:06 EST
Description of problem:
Did you ever try to load http://localhost/phpMyAdmin/changelog.php? I guess, no 
you didn't, because there you'll get

"Warning: file_get_contents(ChangeLog) [function.file-get-contents]: failed to 
open stream: No such file or directory in /usr/share/phpMyAdmin/changelog.php on 
line 9"

which is definately a packaging issue and should be fixed soon.

Version-Release number of selected component (if applicable):
phpMyAdmin-2.9.1-1alpha

How reproducible:
Everytime, see above.

Actual results:
No such file or directory in /usr/share/phpMyAdmin/changelog.php on line 9

Expected results:
Either don't ship changelog.php and rip out the links to changelog.php which is 
personally prefered by me or ship the ChangeLog file in %doc and fix the PHP 
script changelog.php to look in /usr/share/doc/%{name}-%{version}/ for its file 
ChangeLog. Last of it can easily produce problems when having SELinux, this is 
why I would favour the first one.

Additional info:
Ah and you forgot to add your package to owners/owners.list, which I had to do 
to file this bug report...
Comment 1 Mike McGrath 2006-11-15 09:59:56 EST
While I also prefer to have the changelog in /usr/share/doc/ I've left it in the
/usr/share/phpMyAdmin/ as this falls under "If it is in %doc, the program must
run properly if it is not present. "  While this is a very very loose
interpretation, leaving the changelog in /usr/share/phpMyAdmin/ is the easiest /
most maintainable solution.

Note You need to log in before you can comment on or make changes to this bug.