Bug 215195 - system-config-users exit with error after upgrading fc5 > fc6
system-config-users exit with error after upgrading fc5 > fc6
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: system-config-users (Show other bugs)
6
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Nils Philippsen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-12 04:01 EST by cornel panceac
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-02 06:56:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cornel panceac 2006-11-12 04:01:05 EST
Description of problem:

launching system-config-users i get:

"The user database cannot be read.  This problem is most likely caused by a
mismatch between 
/etc/passwd and /etc/shadow or /etc/group and /etc/gshadow.  The program will
exit now."

(in error window)


Version-Release number of selected component (if applicable):


How reproducible:

every time


Steps to Reproduce:
1.launch system-config-users
2.
3.
  
Actual results:
gives an error and exits

Expected results:
launch user and group management interface


Additional info:

this error showed up after upgrading fedora core 5 to fedora core 6
Comment 1 cornel panceac 2006-11-12 04:02:35 EST
$ rpm -q system-config-users
system-config-users-1.2.47-1.fc6

Comment 2 Nils Philippsen 2006-11-13 03:29:14 EST
This is the result of new error checks. Are you sure that your /etc/passwd and
/etc/shadow as well as your /etc/group and /etc/gshadow are consistent, i.e.
every entry present in /etc/passwd or /etc/group must be present in /etc/shadow
or /etc/gshadow? If you start system-config-users from a terminal window, are
there any additional error messages in the terminal window?
Comment 3 cornel panceac 2006-11-13 14:47:53 EST
no, i'm not sure that they are consistent. but, i remember now some strange
things happened on a newly installed fc6: after creating a user with s-c-u, i've
launched gdmflexiserver so that the new user can log in. gdm keeps saying that
the user/password combo was incorrect. i've ctrl-alt-f1, logged as user, su - ,
and changed the password again for the new user. still refusing, i've tried to
switch back to my working account but didn't find it (for unknown reason).
trying to switch back to the newly created display couldn't find it either, so i
switched back to text and ctrl-alt del. after reboot, everything was just fine,
and the new user could login after gdmflexiserver.
repeating the test some other time, logging the new user in gdmflexiserver was
ok, but switching back and forth between gui and tui eventually locked keyboard
(where was supposed to be gui but the gui was no more)so that i had to ssh and
reboot the machine. but that looks like another bug, isn't it? the machine is a
new hp d7600.

if i launch s-c-u from the gnome terminal, i get no other error. s-c-u was
working just fine in fc5. could the error appear because i used both s-c-u and
useradd?

also, worth mentioning that _a lot_ of errors i get from rpm -Va, most annoyng is:
at least one of file's dependencies has changed since prelinking

in the mean time:

# rpm -V setup
S.5....T c /etc/printcap

and

]# rpm -V system-config-users
S.5....T c /etc/sysconfig/system-config-users

and last but no least, thank you very much for your help :)
Comment 4 cornel panceac 2006-11-23 13:29:36 EST
ok, i've checked: /etc/passwd and /etc/shadow have the same entries
the same is true for /etc/group and /etc/gshadow
Comment 5 cornel panceac 2006-12-31 13:39:07 EST
one day i discovered it works again (for unknown reason)
Comment 6 Nils Philippsen 2007-01-02 06:56:24 EST
Glad that it works again. Without further info, I'm closing this bug.

Note You need to log in before you can comment on or make changes to this bug.