This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 215209 - [enh] install boot loader earlier within install
[enh] install boot loader earlier within install
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
i586 Linux
medium Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-12 07:57 EST by David Timms
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-15 18:08:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Timms 2006-11-12 07:57:47 EST
Description of problem:
If something goes wrong during an install, the boot loader might not get
installed since it is the last thing that happens before completing the install.

Version-Release number of selected component (if applicable):
fc6 dvd i386 release

Expected results:
Bootloader could / should be installed / configured as soon as appropriate files
are on the disk. 

Additional info:
In the {occasional} times when an install fails to reach the end, it would have
been good to have a bootable system.

Perhaps the yum transaction could be split into two parts. First would get to
the point packages installed so far would allow grub-install would be run, so
that worst case, the machine could actually boot. Secondly, yum would install
the rest of the selected packages.

Given the amount of time it takes for grub to do it's thing before packages are
actually installed, there might also be an advantage in reduced total package
resolution time because each transaction would be involving fewer packages ?
Comment 1 David Timms 2006-11-15 16:35:34 EST
err1: point _where_ packages 
err2: amount of time it takes for _yum_ to  {I'm awake now}.

There would also the possibility of using the multi-threading capability to
begin partitioning and formatting in the background while package resolution is
taking place; and if this completes before package resolution begins to start
downloading the first packages required; this could also be extended to
downloading packages {network} while installing {disk}.

Note: with kickstart and limited package selection it is possible to be running
in about 15-20 minutes in any case {on a fast machine}.
Comment 2 David Cantrell 2007-03-15 18:08:35 EDT
It's not quite that simple.  The boot loader is arch specific.  If we split the
installation in to two transactions, one for the boot loader set and one for
everything else, we still have the problem of figuring out what else should be
in the boot loader set that would make a system not only bootable, but also
usable.  And once you've reached that point, what is the point really?  You've
gained the same that the rescue CD gives you, but added a ton of complexity to
the installer.

It's a nice idea, but I think we provide enough recovery methods in the cases
where the installation fails and the system is unbootable.

Note You need to log in before you can comment on or make changes to this bug.