Bug 215215 - kickstart install interactive still shows timezone and rootpw screens.
kickstart install interactive still shows timezone and rootpw screens.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
All Linux
medium Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-12 08:56 EST by David Timms
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-13 10:16:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kickstart.cfg file that is being used. (2.14 KB, text/plain)
2006-11-12 08:56 EST, David Timms
no flags Details

  None (edit)
Description David Timms 2006-11-12 08:56:31 EST
Description of problem:
Installer asks user for information for timezone and rootpw.

Version-Release number of selected component (if applicable):
fc6 ks=ftp://

How reproducible:
See included kickstart.cfg, accessed from network boot with ks=ftp://

Steps to Reproduce:
1. place timezone and rootpw info in a ks=cfg file
2. set the type to interactive {so can choose partitioning}
3. linux ks=ftp://...
4. insert partitioning information|next
  
Actual results:
1. timezone screen is shown with ks selected zone is already selected.|next
2. root password screen is shown. need to type and re-type pw|next

Expected results:
since information for the timezone and rootpw screen has already been given in
the ks.cfg, the next screen should be the package resolution screen. 
Also after the numerous minutes of resolution, if resolution is successful, the
installer should begin by itself *without* requiring another next.

Additional info:
It seems that the parameter for timezone is read from the ks file, but just not
acted upon. The rootpw seems to be totally ignored {just clicking next does not
succeed}.
Comment 1 David Timms 2006-11-12 08:56:31 EST
Created attachment 140989 [details]
kickstart.cfg file that is being used.
Comment 2 Chris Lumens 2006-11-13 10:16:31 EST
You have "interactive" specified in your kickstart file, which means to read the
data from your ks file, apply it, and stop at every screen.  If you want a fully
automated install you need to remove that line from the file.
Comment 3 David Timms 2006-11-15 16:25:27 EST
Thanks Chris, I misunderstood the docs to mean use interactive if any user input
is needed at all during kickstart. It would be common to always need user input
in the partitioning/raid/lvm section, and hence my reason to include it.

You are correct in that removing interactive solves the problem; and since I
have no partitioning information set, the only screen then shown is partitioning
step.

Looking at it another way:
With interactive set, steps keyboard, language, {is there another screen before
partitioning ?} are *not* shown, but partitioning {since I included no
partitioning info} and {some/all of} the post partitioning steps are shown, even
though there a values set for all screens {except partitioning}. This seems to
contradict the interactive dsecription supplied.

For the rootpw screen, my kickstart definitely has the pw hash, but * are not
shown in the dual pw fields, and clicking next on this screen pops ~"you must
enter a root pw" message. So I imagine there is something security special about
the pw box that it isn't possible to use the rootpw from kickstart.cfg when
interactive is set ?
Comment 4 Chris Lumens 2006-11-16 13:35:51 EST
The keyboard and language screens are special.  The text mode ones very early on
are not shown even in an interactive install because they're provided by an
entirely different code base.  The graphical ones are not shown unless you boot
with the nopass option, even in an interactive install.  So yes, they do
contradict that description.

The root password screen is also special in that I don't really know what to do
there if user interaction is required.  See bug 181740.  Basically if you hit
the root password screen in any sort of interactive install, we end up throwing
away the password you provided in kickstart.

Which docs did you use?  Perhaps the interactive description there needs
clarification.

Note You need to log in before you can comment on or make changes to this bug.