Bug 215219 - cdrom no longer works after yum update (of kernel, probably)
cdrom no longer works after yum update (of kernel, probably)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-12 10:37 EST by Pierre Francois
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-13 04:48:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre Francois 2006-11-12 10:37:07 EST
Description of problem:


Version-Release number of selected component (if applicable): 2.6.18-1.2239.fc5


How reproducible: always


Steps to Reproduce:
1. boot with kernel 2.6.18-1.2200.fc5 or 2.6.18-1.2239.fc5
2. run "modprobe ide_cd" as root
  
Actual results:
FATAL: Error inserting ide_cd
(/lib/modules/2.6.18-1.2239.fc5/kernel/drivers/ide/ide-cd.ko): Unknown symbol in
module, or unknown parameter (see dmesg)

Expected results:
Loading the module and ability to access /dev/hdc

Additional info:
# dmesg | grep ^ide
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
ide-floppy driver 0.99.newide
ide_cd: Unknown parameter `dma'
ide_cd: Unknown parameter `dma'
Comment 1 Dave Jones 2006-11-12 16:56:53 EST
looks like your /etc/modprobe.conf has a dma parameter in there.
The module doesn't have that option, so it complains.
Comment 2 Pierre Francois 2006-11-13 04:48:34 EST
It hasn't, but I have a file in /etc/modprobe.d/ with such a line. 

options ide-cd dma=1

It was advised on http://freshrpms.net/docs/dvd/ for making ogle and mplayer
play more smoothly, but this idea is obviously outdated now. I will tell them.

The most amazing thing is that I didn't touch my /etc/modprobe.conf file in the
last five monthes, and that the module stopped working only the last weeks.
Probably some change happened in the kernel I didn't notice. I also thought
about that, but since I was "grepping" for ide_cd instead of ide-cd, I didn't
match the line...

Anyway, thanks a lot, Dave.

Note You need to log in before you can comment on or make changes to this bug.