Bug 215234 - pam conflicts with system db4 even though it doesn't use it
Summary: pam conflicts with system db4 even though it doesn't use it
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pam   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 198038
TreeView+ depends on / blocked
 
Reported: 2006-11-12 18:31 UTC by Jindrich Novy
Modified: 2013-07-02 23:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-13 21:53:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jindrich Novy 2006-11-12 18:31:49 UTC
Description of problem:
pam spec file contains "Conflicts: db4 >= %{db_conflicting_version}" even though
it uses its own db4, which is independent on system db4.

Version-Release number of selected component (if applicable):
0.99.6.2-3

How reproducible:
always

Steps to Reproduce:
1. Try to install db4 with higher or equal version than is listed in the pam
spec file.
  
Actual results:
Update of system db4 fails due to useless conflict defined in spec file.

Expected results:
The "Conflicts:" tag is removed from the spec file. Update of system db4 passes
so that pam won't block other packages that need to be rebuilt against new
system db4.

Additional info:
The conflicts tag also makes testing of new db4 releases very hard, because
every time I want to test new db4 package in a chroot, I need to remove/update
this conflict and reinstall pam into chroot by hand.

Comment 1 Robert Scheck 2006-11-12 21:25:45 UTC
Well the conflict IMHO makes sense, but the db4 copy inside of the pam package 
should be updated in Rawhide just _before_ any update of db4:

# We internalize libdb to get a non-threaded copy, but we should at least try
# to coexist with the system's copy of libdb, which will be used to make the
# files for use by pam_userdb (either by db_load or Perl's DB_File module).

Comment 2 Tomas Mraz 2006-11-13 21:53:47 UTC
The conflict cannot be removed for the reasons given above.

pam-0.99.6.2-4.fc7 in tomorrow's rawhide contains updated db4 with the conflict
moved to 4.6.x so hopefully this problem is resolved for now.


Comment 3 Jindrich Novy 2006-11-14 05:55:00 UTC
Thanks. I'm going to ping releg guys so that they move the db4/compat-db back to
buildroots.


Note You need to log in before you can comment on or make changes to this bug.