Bug 215235 - (daniel-magarzo) The Search function in Nautilus 2.16.2 doesn't work for files living in the home dir
The Search function in Nautilus 2.16.2 doesn't work for files living in the h...
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Alexander Larsson
Depends On:
  Show dependency treegraph
Reported: 2006-11-12 13:34 EST by M Daniel Rodriguez Magarzo
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-11-22 05:58:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description M Daniel Rodriguez Magarzo 2006-11-12 13:34:25 EST
Description of problem:
The Search applet in Nautilus 2.16.2 is always unable to find anything placed in
my home directory; given any string to find belonging to an existing file name
located in my $HOME dir, the search ends inmediatly with nothing found. It
doesn't matter whether the string belongs to text content inside any file or
even just text matching the file name itself. Though, the function _do_ really
search in the rest of the tree indeed, since sometimes it finds some files
matching with the given string, but there (in the / partition). 

Version-Release number of selected component (if applicable):
Nautilus 2.16.2
FC6 up to date

How reproducible:
First- Fresh install of FC6 over a laptop (I don't think that the kind of
hardware would be here the problem, but its an IBM ThinkPad T42).
I suspect the problem is in the following:
a) Three partitions for the system, previously already existing (FC5 was placed
before over them). Installation typical via DVD FC6.
b) /boot and / (root) would be formatted (ext3) but I left my previous /home
with the option (Anaconda work) of _preserving data_ (though the mount point was
declared correctly ...) 
c) Mount points, next steps, etc. Everything continued & ended OK. There were
any problem at all. End of install, etc.  
Second- Launch a Nautilus window, and try to use the Search function embebed on
it (righ upper corner), in order to find anything placed in your home...

Steps to Reproduce:
1. Please, see above ---
Actual results:
It does not find any string if this implies any file living in my $HOME.

Expected results:
Search function in Nautilus working with the same behaviour than when the search
is into directories existing in partitions previously formatted when the
installation was done.  

Additional info:
In the last hours I've done another fresh installation in a Desktop system (as I
said, the above took place in my laptop), almost identical steps, package
selection, preferencies, etc... but one big difference (IMHO) was that now the
system was placed in three partitions (previously existing too...) BUT GIVING
FORMAT (ext3) to all them. 
Fortunately, I can confirm that the Search Function of Nautilus here is working
OK (I mean, it finds things in the $HOME dir (as expected, and as I've
experienced always before with any FC system).
Comment 1 Alexander Larsson 2006-11-13 05:16:20 EST
Did the beagle first indexing run have time to finish on the problematic machine?
Comment 2 M Daniel Rodriguez Magarzo 2006-11-13 18:30:24 EST
(In reply to comment #1)
> Did the beagle first indexing run have time to finish on the problematic machine?

Sorry, but I don't catch what is exactly what you mean in your question..; do
you mean whether beagle finds anything (on the laptop)? If that's the question,
the answer is _yes_, it finds mostly web pages (visited) that I suppose it is
indexing, but not files (nor anything) placed in my $HOME.

Did you mean that? If not, please, suggest me the exact commands, etc. and I'll
be pleased to do it. 

p.s.-I'm not familiar with beagle (commands) at all.


Comment 3 Alexander Larsson 2006-11-20 10:05:30 EST
First of all, upgrade to the new beagle update that fixes a hang in beagle.
Then, after log in and a search doesn't finish, use beagle-index-info and
beagle-status to see what beagle is doing and if it has finished the first
indexing run it does after login. Before that is done (the first time) you won't
get all results.
Comment 4 M Daniel Rodriguez Magarzo 2006-11-21 18:54:34 EST
Well, well..
The system was updated yesterday with yum, that update involved the
beagle_update one you announced.
A search using the nautilus embebed applet did not give any variation with
respect to the older behaviour. 
Then, I've shut down the laptop with no more tries. That was yesterday at
midnight. Today, after booting again, and doing through yum a new general update
available (nothing to do with beagle this time), I tried again with the same
procedure..., and yes! Now it finds whatever it should. 

BTW, also beagle by itself is now able to find files in my $HOME, as the
Nautilus Search applet does, everything speedy, alright. The only thing I did
was to wait for the new version of the package in the _core_ repo (instead of to
take it from _testing_), and to update the system regularly. 

With the command "beagle-index-info", the output shows me that it is working OK,
RSS readers, evolution mails, etc,.. E.g. I suppose this one is completely OK:
Name: documentation
Count: 21231
Indexing: False

And with the command "beagle-status", it gives me thins like this:
Count: 575
Status: Waiting for the next trigger time

Pending Tasks:
Scheduler queue is empty.

Future Tasks:
Maintenance 0 (22/11/2006 0:45:22)
Optimize EvolutionMailIndex
Hold until 22/11/2006 20:38:56
Summarizing, I think that the issue was solved with the arrival of the new version. 
Comment 5 Alexander Larsson 2006-11-22 05:58:23 EST
Yeah, i think the indexing progress just hanged for you before due to the X thing.
Comment 6 M Daniel Rodriguez Magarzo 2006-11-22 11:56:57 EST
So, how do you explain that from a new FC install would behave in that way? And
why that didn't happen on my desktop system, also with a FC6 fresh install?
Thank you.
Comment 7 Alexander Larsson 2006-11-23 04:30:21 EST
How is a new install different? There was a thread race that sometimes caused
beagle to hang and stop indexing.

Note You need to log in before you can comment on or make changes to this bug.