Bug 215250 - compiz-0.3.2-1.fc7, cow and nVidia?
compiz-0.3.2-1.fc7, cow and nVidia?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-12 16:40 EST by Stewart Adam
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-27 18:03:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stewart Adam 2006-11-12 16:40:36 EST
Description of problem:
Enabling desktop-effects with compiz-0.3.2-1 makes things go a little crazy on
my nVidia MX/MMX 400 (64MB). No windows will refresh their contents - For
example I can hold alt and the cursor changes to a mouse with a little "+" like
normal when moving a window - But I can't actually see it move. Commands I type
into a open terminal will execute properly, but I can't see myself type. That
is, until I replace compiz with "metacity --replace". Then things refresh again,
and all the changes I made while desktop-effects were running will suddenly
appear. Compiz will run properly with "compiz --replace gconf --use-cow"

Version-Release number of selected component (if applicable):
compiz-0.3.2-1.fc7

How reproducible:
Always

Steps to Reproduce:
1. Enable desktop-effects
2. Wait a few seconds, things freeze up.
4. Blindly click on the terminal, hit <ctrl+c> and type: 'metacity --replace'
5. Things return to normal
  
Actual results:
Compiz makes windows stop "refreshing" their contents

Expected results:
Compiz doesn't freeze the windows
Comment 1 Steve Brown 2006-11-13 13:57:00 EST
Same symptoms here, with latest nVidia binary drivers (v9629).  Adding these
lines to /etc/X11/xorg.conf under "Device" allows compiz 0.3.2-1 to run:
	Option	"AddARGBGLXVisuals" "True"
	Option 	"DisableGLXRootClipping" "True"

Perhaps we could change the RPM to add these lines if it detects an nVidia card?
 The average user probably won't want to do this.

This does fix compiz, but for me it now messes up the decorations:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=215380
Comment 2 Stewart Adam 2006-11-13 17:17:50 EST
> Option 	"DisableGLXRootClipping" "True"
Yup, it does work - I was missing that option, and now after adding that it
works perfectly.
Comment 3 Stewart Adam 2007-03-27 18:03:30 EDT
Since cow is the default for Compiz in the development branch, this isn't an
issue anymore...

Note You need to log in before you can comment on or make changes to this bug.