Bug 215259 - i810: display messed up with compiz-0.3.2-1.fc7
i810: display messed up with compiz-0.3.2-1.fc7
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-12 20:27 EST by Tom London
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-24 11:52:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2006-11-12 20:27:58 EST
Description of problem:
With compiz-0.3.2-1.fc7 installed, screen does not display properly. "Black
holes" on screen where windows are supposed to be, and no text or images displayed.

Cursor changes as mouse is moved, appears typing is working.

As per various postings, I've tried increasing video ram to 80MB and setting
'Option "DisableGLXRootClipping" "True"' in screen section of xorg.conf.

This is on a Thinkpad X60 with '00:02.1 Display controller: Intel Corporation
Mobile 945GM/GMS/940GML Express Integrated Graphics Controller (rev 03)'.

Reverting to compiz-0.0.13-0.32.20060817git.fc6.i386 'makes it work' again.


Version-Release number of selected component (if applicable):
compiz-0.3.2-1.fc7.i386

How reproducible:
every time


Steps to Reproduce:
1. update compiz; reboot
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Caius Chance 2006-11-13 02:24:04 EST
My PC is Thinkpad X60s which is running rawhide (just updated today - 20061113)

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS/940GML
Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/940GML Express
Integrated Graphics Controller (rev 03)

I have similar problem which blank screen will be reverted to 2D desktop when I
killed the compiz process in virtual console. (w/ no WM then)

At the 2D screen, start 'Desktop Effects' will see compiz is not running, then
re-login would be 2D desktop with MetaCity running. If start 'Desktop Effects'
and click on Enable Desktop Effects, screen blanks and back to 2D after half
minute as it abandoned changes by time-out.

-----

Part of ~/.xsession-errors:

libGL warning: 3D driver claims to not support visual 0x5b
GTK Panel of SCIM 1.4.5

compiz: No stencil buffer. Clipping of transformed windows is not going to be
correct when screen is transformed.
Starting SCIM as daemon ...
SCIM has been successfully launched.
Smart Common Input Method 1.4.5

seahorse nautilus module initialized
compiz: water: GL_ARB_fragment_program is missing
Comment 2 Caius Chance 2006-11-13 02:31:37 EST
BTW, FYI:

In compiz.spec:

http://www.freedesktop.org/Software/compiz

should be:

http://www.freedesktop.org/Software/Compiz ("C"ompiz)

because the wiki website is case-sensitive.

Comment 3 Tom London 2006-11-16 09:46:07 EST
Just updated to compiz-0.3.2-2.fc7, and it work 'better': background and windows
are properly displayed, but window decorations are missing.

Selecting System->Preferences->Desktop Effects and pressing 'Enable Desktop
Effects' appears to disable compiz. Clicking 'Enable Desktop Effects' again
enables it this time turning on window decorations.

Have to repeat the above each time I login....
Comment 4 Tom London 2006-11-24 11:52:36 EST
This is 'working for me' with compiz-0.3.4-1.fc7.

Related issue was the renaming of 'gnome-window-decorator' to
'gtk-window-decorator'. Updating session startup command to this fixes...

Note You need to log in before you can comment on or make changes to this bug.