Bug 215264 - SHFT-CTL-ALT-<[left|right] arrow> doesn't initially drag current window when moving between desktops.
SHFT-CTL-ALT-<[left|right] arrow> doesn't initially drag current window when ...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-12 22:43 EST by Rodd Clarkson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-28 23:46:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rodd Clarkson 2006-11-12 22:43:03 EST
Description of problem:

You can use SHFT-CTL-ALT-<[left|right] arrow> to move the currently focused
window from one desktop to the next, but it (often) doesn't work on the initial
attempt.

Strangely, you often need to use CTL-ALT-<[left|right] arrow> twice (once to
move to another desktop, and again to return) before SHFT-CTL-ALT-<[left|right]
arrow> works.

I suspect that the application is grabbing the keystrokes and that the move from
one desktop to another and back releases this and allows the SHIFT to 'hold' the
window.


Version-Release number of selected component (if applicable):


compiz-0.0.13-0.32.20060817git.fc6


How reproducible:

Frequently.  I works some times, other times it doesn't.


Steps to Reproduce:
1.  At various moments try using SHFT-CTL-ALT-<[left|right] arrow> the currenly
focused window to another desktop.  If often doesn't come without the hack above.
Comment 1 Kristian Høgsberg 2007-03-28 22:36:30 EDT
I can't reproduce this, does it still happen with the latest compiz and X
server?  Have you noticed anything special when this happens, is there some kind
of pattern?
Comment 2 Rodd Clarkson 2007-03-28 23:46:02 EDT
This seems to have resolved itself.  I can't trigger it in any case.

Note You need to log in before you can comment on or make changes to this bug.