Bug 215268 - kdump service will not start
kdump service will not start
Product: Fedora
Classification: Fedora
Component: kexec-tools (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Vivek Goyal
Linda Wang
Depends On:
  Show dependency treegraph
Reported: 2006-11-13 00:20 EST by Need Real Name
Modified: 2008-05-06 12:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-06 12:48:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2006-11-13 00:20:40 EST
Description of problem:
kdump service will not start with kernel versions above 2.6.17-1.2174_FC5smp

Version-Release number of selected component (if applicable):
 > 2.6.17-1.2174_FC5smp

How reproducible:

Steps to Reproduce:
1. Boot system with kernel version > 2.6.17-1.2174_FC5smp 
2. add "crashkernel=128M@16M" to kernel command line
3. /sbin/service kdump start
Actual results:
Base address: 125e880 is not page aligned

Expected results:
Kdump starts.

Additional info:
I've tried different sizes for the crashkernel option without success.
Comment 1 Vivek Goyal 2006-11-13 09:07:24 EST
Looks like this is a problem that all the segments in vmlinux are not on page
aligned boundary. Most likely it should be fixed by my patch which is in Andi's
tree and in -mm.


Comment 2 Frank Ch. Eigler 2006-11-26 21:47:34 EST
According to the FC5 kernel changelog, this was fixed.

* Thu Sep 28 2006 Dave Jones <davej@redhat.com>
- Another day, another round of lockdep fixes.
- Align kernel data segment to page boundary. (#206863)

However, bug 206863 was opened against FC6, and the current FC5
kernel (kernel-2.6.18-1.2239.fc5.i686) still has the bug.
Comment 3 Need Real Name 2006-11-26 23:18:35 EST
Sorry, I should have mentioned the latest kernel I had tried this on instead of
relying on the date of my post (Nov 13) to be an indication of which versions of
the kernel I was talking about.

2.6.18-1.2239.fc5smp has this bug.

[root@server1 ~]# uname -r
[root@server1 ~]# /sbin/service kdump start
Base address: 125e880 is not page aligned
Comment 4 Red Hat Bugzilla 2007-05-03 00:52:02 EDT
User vgoyal@redhat.com's account has been closed
Comment 5 Bug Zapper 2008-04-04 00:38:20 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 6 Bug Zapper 2008-05-06 12:48:01 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.