Bug 215278 - wargames broken
wargames broken
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: bsd-games (Show other bugs)
6
All Linux
medium Severity low
: ---
: ---
Assigned To: Wart
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-13 02:02 EST by Michel Alexandre Salim
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-22 20:03:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2006-11-13 02:02:17 EST
Description of problem:
The wargames script, part of the bsd-games collection, searches for the user's
input in /usr/games/, and if found, executes it. All game binaries are now
located in /usr/bin, however, so no matter what one types one gets back the
failsafe option:

A strange game.
The only winning move is
not to play.

Version-Release number of selected component (if applicable):
bsd-games-2.7-15.fc6

How reproducible:
Always


Steps to Reproduce:
1. wargames
2. Type in the name of a bsd-games binary
  
Actual results:
Game not launched

Expected results:
Game launched

Additional info:
Comment 1 Wart 2006-11-18 19:42:33 EST
After taking a closer look at this 'game', I'm not sure it should even be
included.  It's just a launcher for other games that are already in the user's PATH.

I'm going to 'fix' this by removing wargames from this package.
Comment 2 Michel Alexandre Salim 2006-11-19 23:04:00 EST
It is quite humorous, though. Can't you leave it in, but change it so it checks
that the name typed matches one of the game installed by bsd-games?
Comment 3 Wart 2006-11-21 13:13:09 EST
Since all of the bsd-games are installed in /usr/bin, it would require rewriting
the logic in wargames to filter only on games from bsd-games.  I could instead
have it operate on anything in /usr/bin, instead of /usr/games, but I'd really
prefer just to remove wargames.
Comment 4 Wart 2006-11-22 20:03:33 EST
'wargames' has been removed for FC6 and rawhide.

Note You need to log in before you can comment on or make changes to this bug.