Bug 215328 - install dies with "undefined symbol: universe_hash"
install dies with "undefined symbol: universe_hash"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
rawhide
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2006-11-13 10:28 EST by Prarit Bhargava
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-13 13:57:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prarit Bhargava 2006-11-13 10:28:37 EST
Description of problem:

Latest nightly install dies with "undefined symbol: universe_hash"

Version-Release number of selected component (if applicable): rawhide-20061113


How reproducible: 100%


Steps to Reproduce:
1. Install from boot.img's vmlinuz and initrd
2. Select NFS install
  
Actual results:

After installer starts, dies with

File "/usr/bin/anaconda, line 592, in ?
  import signal, traceback, string, isys, iutil, time
File "/usr/lib/anaconda/isys.py", line 18, in ?
  import _isys
ImportError: /usr/lib/libdhcp4client.so.1: undefined symbol: universe_hash
install exited abnormally [1/1]

(snip)

Expected results:  Install should succeed.


Additional info: Seen on new HP rx2680 in Prarit's cube.  I haven't done any
additional debugging yet ... just entering in the BZ.
Comment 1 Prarit Bhargava 2006-11-13 10:30:02 EST
Hmmm ... looks like a libdhcp issue?
Comment 2 David Cantrell 2006-11-13 12:11:20 EST
Well, this is a dhcp issue, but part of the libdhcp4client patch.  Thanks for
the report.
Comment 3 David Cantrell 2006-11-13 13:57:29 EST
Fixed in rawhide.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.