Bug 215335 - Xorg memory leak when using kde random background function
Xorg memory leak when using kde random background function
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-13 11:05 EST by Norman R. Weathers
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-04 13:17:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Norman R. Weathers 2006-11-13 11:05:10 EST
Description of problem:
Serious xorg memory leak when using KDE's Background changing functionality
(Desktop background changing to random pictures).

Version-Release number of selected component (if applicable):
3.5.x

How reproducible:
All the time

Steps to Reproduce:
1. Right click on KDE desktop, choose Configure Desktop, slideshow, choose a
bunch of pictures, set random and a time of 5 minutes.
2. Monitor top during each background change.  With my 2 monitor desktop (does
use NVidia card and driver), and it uses up ~ 5 and 17 MB per change and is
never freed.  Over a typical weekend, I had used up over 4 GB for Xorg server.

  
Actual results:
Swaps out.  Xorg uses over 8GB virtual mem (~ 2 - 4 GB real).  Node becomes slow.

Expected results:
It shouldn't take up the extra memory at each change and never release it.

Additional info:

Backing Store and Save-unders enabled.  I am using an NVidia card with an NVidia
driver.  I have seen this primarly on x86_64 (64 bit).  I am seeing this with
and without KDE translucency enabled.
Comment 1 Ngo Than 2006-11-13 11:30:06 EST
i cannot reproduce this issue with KDE.3.5.5 in FC6-update. Which kde version 
did you install on your machine? please attach the output of "rpm -qa | grep 
kde". Does the problem appear if you use the opensource nv driver? Does the 
problem appear with gnome-desktop?
Comment 2 Sammy 2006-11-15 12:07:25 EST
I can see something similar to this with the ati fglrx driver.

If I am building an rpm from source and it is writing a whole bunch
of stuff to the console very rapidly than the CPU used by X is going
up to 80%. As soon as the writing on the konsole slows down CPU goes 
down too. Some kind of rendering issue but I am not sure where the 
problem lies! KDE, Xorg, ?
Comment 3 Ngo Than 2006-11-16 06:02:08 EST
could please attach the output of "rpm -qa | grep kde". Does the problem 
appear with gnome-desktop? it seems a bug in Xorg
Comment 4 Norman R. Weathers 2006-11-27 23:27:30 EST
This is appearing to be a problem, so far, with KDE random background and 3rd
party graphics drivers.  I have a laptop running FC6 using the random background
setting for KDE using latest updates for KDE, and after 5 days of being up, plus
running the KDE translucency setting for 4 of the 5 days, I only have used ~ 110
MB real (377 MB virtual), which is what I would expect for all of the usage that
my laptop gets (several tabs open in Firefox, plus open images, plus several
terminals open, and VNC viewer running).  I tend to think that it is a
combination of the third party driver (in my case Nvidia, and in the other
persons comment, the fglrx, which I have had nothing but problems with on this
laptop.  In fact, I have better luck running the ati open driver than the fglrx
driver for my mobile radeon.  Just goes to show about open source
programming...).  Anyway, do you have any channels that I should submit this up
to through NVidia to see if they have any info.  This has been happening for a
while (Even through FC5, and maybe even FC4).

Thanks, Norman
Comment 5 Ngo Than 2006-12-04 13:17:53 EST
there's a forum
http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Note You need to log in before you can comment on or make changes to this bug.