Bug 215353 - X server crashes when switching back from a VT
X server crashes when switching back from a VT
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-13 11:57 EST by Alan Stern
Modified: 2007-12-11 16:01 EST (History)
3 users (show)

See Also:
Fixed In Version: Fedora 8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-11 16:01:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file from a test session (97.88 KB, text/plain)
2006-11-13 11:57 EST, Alan Stern
no flags Details
My xorg.conf configuration file (3.41 KB, text/plain)
2007-01-02 12:16 EST, Alan Stern
no flags Details
Xorg log file from a session with xorg.conf renamed (101.84 KB, text/plain)
2007-01-02 12:17 EST, Alan Stern
no flags Details
Xorg.0.log initial section (62.16 KB, text/plain)
2007-04-23 17:53 EDT, Alan Stern
no flags Details
Xorg.0.log after switching to a VT (464 bytes, text/plain)
2007-04-23 17:54 EDT, Alan Stern
no flags Details
Xorg.0.log final section, after trying to switch back to X (32.76 KB, text/plain)
2007-04-23 17:57 EDT, Alan Stern
no flags Details

  None (edit)
Description Alan Stern 2006-11-13 11:57:36 EST
Description of problem: When I switch from the X console to a normal VT and then
back to X, the X server crashes.

Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-1.6.5-9.fc6
xorg-x11-server-Xorg-1.1.1-47.fc6

How reproducible: Always

Steps to Reproduce: Start X, then press Ctrl-Alt-F1, then press Ctrl-Alt-F7.

Actual results: A distorted image appears on the screen for a couple of seconds,
then the screen goes blank.  There is no apparent response to regular key
presses, although Alt-SysRq-B does cause the system to reboot.

Expected results: The X session ought to resume normally.

Additional info: Attached is the Xorg.0.log file from a test.  I have noted the
points at which the VT switches took place.  The most interesting parts are
right at the end; they look like this:

Error in I830WaitLpRing(), now is -502068384, start is -502070385
pgetbl_ctl: 0xffe0001 pgetbl_err: 0x49
ipeir: 0 iphdr: 0
LP ring tail: 5f0 head: 0 len: 1f001 start 0
eir: 0 esr: 10 emr: ff7b
instdone: ffc1 instpm: 0
memmode: 0 instps: 20
hwstam: fffe ier: 82 imr: 53c iir: 0
space: 129544 wanted 131064
(II) I810(0): [drm] removed 1 reserved context for kernel
(II) I810(0): [drm] unmapping 8192 bytes of SAREA 0xd0a21000 at 0xb7ee9000

Fatal server error:
lockup

Conceivably this is caused by a kernel bug, but nothing showed up in the system
log (captured using a serial console).
Comment 1 Alan Stern 2006-11-13 11:57:36 EST
Created attachment 141072 [details]
Xorg log file from a test session
Comment 2 Matěj Cepl 2006-12-28 18:10:00 EST
Hi, sorry for the late response to your report, but unfortunately I would still
like to see your /etc/X11/xorg.conf as well. Could you please attach it to this
bug as well? Also, could you try to remove /etc/X11/xorg.conf altogether and try
to replicate the bug?
Comment 3 Alan Stern 2007-01-02 12:16:03 EST
Created attachment 144650 [details]
My xorg.conf configuration file

This is my xorg.conf file.  The same problems occurs when I rename it before
starting X.
Comment 4 Alan Stern 2007-01-02 12:17:50 EST
Created attachment 144651 [details]
Xorg log file from a session with xorg.conf renamed

Here's the Xorg log file from a test session in which xorg.conf was renamed and
hence not found by the X server.
Comment 5 Martial boudant 2007-04-22 12:26:36 EDT
After many try i solved the VT switch bug on I965 chipset by adding this
parameter in xorg.conf

so you can try this fix

Option "HWCursor" "off"
Comment 6 Alan Stern 2007-04-23 17:51:25 EDT
(Note that my chipset is i845G, not i965.)

According to the xorg.conf and the i810 man pages, there is no "HWCursor"
option.  And when I tried using it, the Xorg.0.log file showed that it wasn't
recognized.  But there is a "SWCursor" option, so I added

    Option "SWCursor" "on"

to the Device section in xorg.conf.  It didn't help; the same problem still
occurred.  I will attach the sections of Xorg.0.log from before before switching
to vt1, after switching to vt1, and after switching back to vt7.
Comment 7 Alan Stern 2007-04-23 17:53:21 EDT
Created attachment 153318 [details]
Xorg.0.log initial section

Initial part of the log, before I switched back to a VT.
Comment 8 Alan Stern 2007-04-23 17:54:41 EDT
Created attachment 153319 [details]
Xorg.0.log after switching to a VT

Middle section of Xorg.0.log, from after I switched back to a VT.
Comment 9 Alan Stern 2007-04-23 17:57:01 EDT
Created attachment 153320 [details]
Xorg.0.log final section, after trying to switch back to X

Final section of Xorg.0.log, including the errors that occurred after I
switched from a VT back to X.  Note the error messages near the end, coming
from I830WaitLpRing().	I don't know what the LP ring is, but it seems to be
the source of the trouble.
Comment 10 Matěj Cepl 2007-12-10 04:24:58 EST
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Xorg or
Gecko. If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]
Comment 11 Alan Stern 2007-12-11 16:01:41 EST
The problem doesn't occur under Fedora 8.  Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.