Bug 215355 - libxml2-python shouldn't require /usr/lib/python2.4
libxml2-python shouldn't require /usr/lib/python2.4
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libxml2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-13 12:19 EST by Mark McLoughlin
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: libxml2-2.6.29-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-20 17:00:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2006-11-13 12:19:55 EST
I don't think there's any reason for libxml2-python to require /usr/lib/python2.4

i.e. this is bogus:

Requires: %{_libdir}/python%(echo `python -c "import sys; print sys.version[0:3]"`)
Comment 1 Mark McLoughlin 2006-11-13 13:21:47 EST
I think python will automatically insert a "Requires: python(abi) = 2.4" ...
which should be enough
Comment 2 Daniel Veillard 2006-11-13 18:11:57 EST
Should not require ... why ?
w.r.t. #1, maybe rpm in the build system of Fedora, on that peticuliar release
may actually do the right thing. I want my source package to work on a variety
of systems, that's the reason.

So what is the reason why you want to get rid of this ? What error did you 
face, if none, sorry I won't change it :-)

Daniel
Comment 3 Mark McLoughlin 2006-11-13 18:40:16 EST
/usr/lib/python2.4 just isn't something which is sane to require ...

Sorry, I don't really have a good way of explain why not, right now ... but look
at any other python package :)

The specific problem was that using yum's "repotrack" to build a closed repo of
packages which included libxml2-python ended up with KDE, gtk2 and others
because the likes of kdebindings was accidently providing /usr/lib/python2.4 -
see #196311

So, two bugs were conspiring together ... kdebindings providing
/usr/lib/python2.4 and libxml2-python requiring it.

Maybe I just need to get one of the Fedora packaging dudes on your ass :-P
Comment 4 David Lutterkort 2006-11-13 21:00:09 EST
If you need the specfile to work for other distros, you can use the dist tag set
by the Fedora build system to do the right thing for Fedora and other things for
other distros (though I don't see why requiring a directory that happens to be
the install location for python is _ever_ the right thing) 

See http://fedoraproject.org/wiki/Packaging/DistTag; for distros that don't have
'python(abi)' you'd probably want to require just 'python >= 2.4' or some
variation thereof
Comment 5 Daniel Veillard 2007-06-20 17:00:27 EDT
That was fixed in the last Fedora releases, like libxml2-2.6.29-1.fc7

Daniel

Note You need to log in before you can comment on or make changes to this bug.