Bug 215358 - Invalid permission of file /usr/sbin/suphp
Invalid permission of file /usr/sbin/suphp
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: mod_suphp (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Andreas Thienemann
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE7Target
  Show dependency treegraph
 
Reported: 2006-11-13 12:23 EST by adhisimon
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-10 16:38:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description adhisimon 2006-11-13 12:23:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.8) Gecko/20061108 Fedora/1.5.0.8-1.fc5 Firefox/1.5.0.8

Description of problem:
File /usr/sbin/suphp has wrong permission . It would prevent httpd create child process because it can not read and execute it because it prevent user/group other than root/root to read and execute it (httpd runs on apache/apache)

Version-Release number of selected component (if applicable):
mod_suphp-0.6.1-4.fc5

How reproducible:
Always


Steps to Reproduce:
1. Access a page served by mod_suphp


Actual Results:
It will get "Internal Server Error" message and httpd error log will contain:
Permission denied: couldn't create child process

Expected Results:
The page content show nicely

Additional info:
Single command to solve this problem is:
chmod o+rx /usr/sbin/suphp
Comment 1 Sitsofe Wheeler 2006-11-14 18:14:37 EST
I believe a better solution is to ensure that suphp is in the apache group.
Comment 2 Sitsofe Wheeler 2006-11-18 13:58:09 EST
Just to clarify, in the spec file I think:
%attr (4550, root, root) %{_sbindir}/suphp 
should be
%attr (4550, root, apache) %{_sbindir}/suphp

This means only root and apache will be able to run the setuid binary which is
the way that suexec does things too.
Comment 3 Andreas Thienemann 2007-03-10 16:38:43 EST
Thx, package is updates as suggested in comment #2.

Note You need to log in before you can comment on or make changes to this bug.