Bug 215367 - wireless install fails
wireless install fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
: 221415 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-13 13:03 EST by Sean Dilda
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-28 14:40:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Dilda 2006-11-13 13:03:50 EST
I have an IBM T40 with a Cisco AIRONET wireless card.

I tried to install anaconda.  I selected an HTTP install.  For my network
device, I chose the 'AIRONET Wireless Communications Cisco Aironet Wireless 802.11b'


I'm then presented with a screen for 'Wireless Settings'.  The first field is
for ESSID.  Its already filled in with the current contents:
ami33333333333333333333333333<CC><CC><CC>^Q_
The cursor is under the first '<'.  Also, the pre-filled in text extends beyond
the window and into the blue part of the screen.

Hitting backspace in this field does nothing and trying to input data causes a beep.

As I'm unable to set the ESSID, I'm unable to continue with the install.
Comment 1 Jeremy Katz 2006-11-16 14:41:44 EST
You can probably workaround this by booting with 'essid=foo' on the kernel
command line.

The fix is that we should probably initialize things better in
isys/wireless.c:get_essid()
Comment 2 Paul Jenner 2006-11-18 15:55:37 EST
I see the same issue here.

<ctrl>-U clears the ESSID field in the dialogue and allows me to enter my own
but then it appears not to connect to the network (still investigating but at
least DHCP does not work).

Booting installer with "linux essid=foo" did nothing for me - the wireless
settings dialogue still showed the ami3333 text reported.
Comment 3 David Cantrell 2006-11-28 14:40:44 EST
Unitialized structures lead to pain and suffering.  Committed to devel branch. 
Thanks.
Comment 4 David Cantrell 2006-11-28 14:41:10 EST
And see, what I meant to say was _uninitialized_.
Comment 5 Jeremy Katz 2007-01-04 16:37:12 EST
*** Bug 221415 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.