Bug 215440 - circular build dependency for php-pear and php
circular build dependency for php-pear and php
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: php-pear (Show other bugs)
5
All Linux
medium Severity low
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-13 18:03 EST by Jim Perrin
Modified: 2014-01-21 17:55 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-14 10:23:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Perrin 2006-11-13 18:03:48 EST
Description of problem:
php-pear requires php to build. php requires php-pear to install.
php cannot be installed via a mock style build setup to build php-pear, because
it requires php-pear.


Version-Release number of selected component (if applicable):
php-pear-1.4.9-1.2 and php php-5.1.6-1.2

How reproducible:
Always

Steps to Reproduce:
1. remove php-pear from mock build repository (to 'start fresh')
2. build php and create metadata for build repo to use php (builds fine)
3a. (cheat, and run repoclosure to see the missing php-pear)
3b. go the full build route, and attempt to build php-pear.

Actual results:
build will fail because php cannot be installed without php-pear

Expected results:
build succeeds and build system is allowed to work 

Additional info:
Previous versions of php-pear complete the dependency allowing it to be built,
but the dependency chain is not 100% proper.
Comment 1 Joe Orton 2006-11-14 10:23:07 EST
This is intentional to preserve php-pear on upgrades.
Comment 2 Seth Vidal 2006-11-14 13:33:35 EST
to preserve it on upgrades? It's not possible to rebuild it from raw packages.
How does that preserve anything?
Comment 3 Joe Orton 2006-11-14 15:07:54 EST
I meant to preserve the existence of PEAR on the system from when PEAR was not
split out from the php package.

php-pear BRs php is a genuine build dependency.
Comment 4 Seth Vidal 2006-11-14 15:16:58 EST
php-pear BR's php
php Requires php-pear for install.

so when you make the chroot to build in - you cannot build php-pear w/o first
having a php-pear available.


circular dep.
Comment 5 Joe Orton 2006-11-14 15:28:20 EST
Yes Seth, it's a circular dependency, it's perfectly intentional, and it's not a
bug.

At some point the "php Requires php-pear" dependency can be dropped when we no
longer have to care about upgrades from distros without the php-pear package
split, but not yet and certainly not from the FC5 package.
Comment 6 Seth Vidal 2006-11-14 15:36:21 EST
And all I'm saying is that it is impossible to build the packages with a
circular dep w/o first having the package. As long as that's clear and isn't
propagated into fc6 and therefore rhel5.


Note You need to log in before you can comment on or make changes to this bug.