Bug 215446 - Header file /usr/include/linux/serial_reg.h not installed
Summary: Header file /usr/include/linux/serial_reg.h not installed
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 6
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-13 23:58 UTC by Charles Sullivan
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-25 08:46:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Charles Sullivan 2006-11-13 23:58:33 UTC
Description of problem:
The header file serial_reg.h is not installed.  It should be located in
directory /usr/include/linux

Version-Release number of selected component (if applicable):
/usr/src/kernels/2.6.18-1.2849.fc6-i686/

How reproducible:
The file was not installed with the original FC-6 kernel
(2.6.18-1.2798.fc6-i686) or the update 2.6.18-1.2849.fc6-i686 

Steps to Reproduce:
1.  Install FC-6 from distribution DVD.
2.  ls /usr/include/linux/serial_reg.h

Actual results:
  ls: /usr/include/linux/serial_reg.h: No such file or directory

Expected results:
This file should be installed in directory /usr/include/linux as it was in
previous versions of Fedora Core (and Red Hat before that).

Additional info:
The file is included with the kernel, i.e.,
/usr/src/kernels/2.6.18-1.2798.fc6-i686/include/linux/serial_reg.h
/usr/src/kernels/2.6.18-1.2849.fc6-i686/include/linux/serial_reg.h

Comment 1 David Woodhouse 2006-11-25 08:46:17 UTC
Absent justification for using this kernel-private header in userspace.

Comment 2 Charles Sullivan 2006-11-25 14:18:15 UTC
Was it always kernel-private? 

For whatever reason the header was included in some 10-year-old software which
proceeded to break under FC-6 because of its removal.

Deleting the header from the software appears not to cause a problem under FC-6,
but I can only keep my fingers crossed that the software will continue to work
properly without it for users running older versions of Linux.

Comment 3 David Woodhouse 2006-11-26 11:55:38 UTC
Fairly much, yes. We were never so coherent about exporting headers as we are in
the kernel nowadays, but it never made much sense to be including serial_reg.h
from userspace -- not unless you were trying to poke at UARTs directly, which
you really shouldn't be doing.

Comment 4 Charles Sullivan 2006-11-26 13:19:07 UTC
Thanks David.  I appreciate the explanation.


Note You need to log in before you can comment on or make changes to this bug.