Bug 215452 - Replacing -D<DEFINE> with AC_DEFINE to reduce the compile command line length
Replacing -D<DEFINE> with AC_DEFINE to reduce the compile command line length
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Unknown (Show other bugs)
1.0.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Noriko Hosoi
Viktor Ashirov
:
Depends On:
Blocks: 152373 240316 FDS1.1.0
  Show dependency treegraph
 
Reported: 2006-11-13 21:05 EST by Noriko Hosoi
Modified: 2015-12-07 11:38 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 11:38:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
cvs diff configure.ac (3.40 KB, patch)
2006-11-13 21:05 EST, Noriko Hosoi
no flags Details | Diff
cvs diff configure.ac (3.30 KB, patch)
2006-11-14 21:05 EST, Noriko Hosoi
no flags Details | Diff
cvs commit (configure.ac configure config.h.in) (704 bytes, text/plain)
2006-11-14 21:08 EST, Noriko Hosoi
no flags Details

  None (edit)
Description Noriko Hosoi 2006-11-13 21:05:09 EST
Description of problem:
In the review of [214533], Nathan suggested to add the platform dependent define
macros to config.h and eliminate the lengthy "-D<define>" from the compile
command line.  I also think that's a good idea.

So, here's the proposed diff...

Here are some issues I'd like to have your comments.
1. autoheader does not like 
   AC_DEFINE([XP_UNIX], [1]) nor AC_DEFINE([XP_UNIX], [1], [])
   It looks it requires some description.
   (actually, it makes sense since the description appears as a comment for
    the macro)
   Are these descriptions appropriate?
2. There are some macros which do not appear in the source codes (DS as well
   as the components).
   There are two kinds.
   a. CPU_ia64 or HPUX11_##: they'd be useful if such platform dependency
      needs to be supported.
   b. _PR_NTHREAD: do we want to keep this?
3. This is minor, but only Linux does not have "CPU_xxx" and "OS_linux" macros.
   Do we want to add them?
Comment 1 Noriko Hosoi 2006-11-13 21:05:09 EST
Created attachment 141127 [details]
cvs diff configure.ac
Comment 2 Nathan Kinder 2006-11-14 11:09:27 EST
The changes look good.  Here are my comments on your questions:

1. The descriptions look fine.
2. If they are not being used, I'd rather just get rid of them.
3. I think we have too many OS macros as it is, so I'd rather not add more.
Comment 3 Noriko Hosoi 2006-11-14 21:05:28 EST
Created attachment 141206 [details]
cvs diff configure.ac

Thank you for reviewing the changes, Rich and Nathan.

Following the comments by Nathan, I removed the unused "_PR_NTHREAD" macro and
tested on HP-UX.
Comment 4 Noriko Hosoi 2006-11-14 21:08:38 EST
Created attachment 141207 [details]
cvs commit (configure.ac configure config.h.in)

Checked in into HEAD.
Comment 5 Noriko Hosoi 2007-11-29 18:04:49 EST
Checked source tree:
$ pwd
/share/dev4/ds/ds80/builds/20071129.1/earthquake_rhel4/ldapserver

There is no platform_defs which used to be used to pass macro with -D to make.
$ egrep platform_defs configure.ac
$

Also config.h.in is in the tree.

I.e., verified.

Note You need to log in before you can comment on or make changes to this bug.