Bug 215483 - no diagnostic when remote queue misconfigured
no diagnostic when remote queue misconfigured
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Depends On:
  Show dependency treegraph
Reported: 2006-11-14 05:47 EST by Filip Miletic
Modified: 2008-05-06 12:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-06 12:49:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
The log file made by strace, as requested (33.09 KB, text/plain)
2006-12-08 08:07 EST, Filip Miletic
no flags Details
The second strace log (149.73 KB, text/plain)
2006-12-08 08:44 EST, Filip Miletic
no flags Details
Third strace requested (8.33 KB, text/plain)
2006-12-08 09:17 EST, Filip Miletic
no flags Details

  None (edit)
Description Filip Miletic 2006-11-14 05:47:22 EST
Description of problem:
The print button in evince is greyed out for a particular printer.  
The following is printed on the console when I select the printer:
** (evince:4764): WARNING **: Error result: HTTP Error in GET Success

In FC5 I could print just fine.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Start evince from command line with a PS document
2. Select the offending printer (not sure how you can reproduce this...)
3. Try printing.
Actual results:
The print button is greyed out, the warning message gets printed

Expected results:
Printer should be accessible.

Additional info:
Comment 1 Austin Jackson 2006-11-20 12:38:18 EST
I can confirm this in evince and writer on the latest FC6 with all updates
installed.  I have tried different printers as well as changing printer
configuration options, but nothing worked.  This happens for me with any
printer, but I can print to file.  Firefox (I have v2 installed) prints just
fine.  Version numbers:

Comment 2 Tim Waugh 2006-12-08 06:27:52 EST
What gtk2 version have you got installed?
Comment 3 Filip Miletic 2006-12-08 06:46:37 EST
For me, it is gtk2-2.10.4-6.fc6.
Comment 4 Tim Waugh 2006-12-08 06:56:58 EST
And do you still see this problem?
Comment 5 Filip Miletic 2006-12-08 07:31:31 EST
Comment 6 Tim Waugh 2006-12-08 07:53:08 EST
Please attach a strace log, generated as follows:

strace -s1000 -econnect,sendto,recvfrom -f evince 2>strace.log

When evince starts, load a document and go to print it, and wait until you
expect to see the Print button clickable and it isn't.  Then cancel the dialog
and close evince.  Attach the resulting strace.log file here.
Comment 7 Filip Miletic 2006-12-08 08:07:41 EST
Created attachment 143142 [details]
The log file made by strace, as requested

Here goes the log as you required.
Comment 8 Tim Waugh 2006-12-08 08:35:16 EST
Hmm, please try this instead.  Looks like that arch uses send/recv instead of

strace -s1000 -econnect,send,recv -f evince 2>strace.log

Thanks for helping out.
Comment 9 Filip Miletic 2006-12-08 08:44:46 EST
Created attachment 143145 [details]
The second strace log

The second strace log as you requested
Comment 10 Tim Waugh 2006-12-08 09:05:19 EST
It's trying to fetch the PPD for the printer known as ijssel:

[pid  9407] send(19, "GET /printers/ijssel.ppd HTTP/1.1\r\nHost:
mecups.et.tudelft.nl\r\nUser-Agent: CUPS/1.2.7\r\n\r\n", 89, 0) = 89
[pid  9407] recv(19, "HTTP/1.1 404 Not Found\r\nDate: Fri, 08 Dec 2006 13:41:58
GMT\r\nServer: CUPS/1.1\r\nContent-Language: en\r\nUpgrade:
TLS/1.0,HTTP/1.1\r\nConnection: close\r\nContent-Type:
text/html\r\nContent-Length: 138\r\n\r\n<HTML><HEAD><TITLE>404 Not
Found</TITLE></HEAD><BODY><H1>Not Found</H1>The requested resource was not found
on this server.</BODY></HTML>\n", 2048, 0) = 333

** (evince:9407): WARNING **: Error result: HTTP Error in GET Success

but this is failing.

Please paste the following lines into a terminal window:

strace -s1000 -econnect,send,recv,close \
python -c "import cups;c=cups.Connection();c.getPPD('ijssel')" \

and attach the resulting cups.log file.  Thanks.
Comment 11 Filip Miletic 2006-12-08 09:17:51 EST
Created attachment 143149 [details]
Third strace requested
Comment 12 Tim Waugh 2006-12-08 09:28:44 EST
What sort of machine is mecups.et.tudelft.nl, and what is it running?  What
about the printer 'ijssel' -- can you tell me more about that?
Comment 13 Filip Miletic 2006-12-08 09:40:33 EST
mecups is a linux box.  I do not know other data; which details would help?

ijssel is a Nashuatec Aticio 2205 that sits on our LAN. I used to be able to
print fine on it through evince.

Can you be more specific? What do you need to know?
Comment 14 Tim Waugh 2006-12-08 09:45:27 EST
> mecups is a linux box.  I do not know other data; which details would help?

For example, is it running Fedora Core 6, or Fedora Core 5, or some other
distribution?  Which version of CUPS is it running?

> ijssel is a Nashuatec Aticio 2205 that sits on our LAN. I used to be able to
> print fine on it through evince.

By "sits on our LAN" do you mean that the device is directly connected to the
Ethernet, or that it is connected to mecups.et.tudelft.nl which is on the LAN?

If it's connected to mecups.et.tudelft.nl, as seems to be the case, how is it
configured on that machine?  What PPD file is used for it?

The problem comes from the fact that CUPS on Fedora Core 6 cannot fetch the PPD
file to describe that printer, so I'm trying to find out why that would be.
Comment 15 Filip Miletic 2006-12-08 09:52:11 EST
(In reply to comment #14)
> For example, is it running Fedora Core 6, or Fedora Core 5, or some other
For more info I need to consult the system admin, and get the permission to
actually give you that info.

Please be patient until I get this. Shouldn't take too long.
Comment 16 Filip Miletic 2006-12-11 05:56:19 EST
Talking to the sysadmin helped indeed. It seems that the PPD file for ijssel had
been inadvertently removed from the queue manager's filesystem.  The sysadmin
recovered it and printing is now possible.  Hence, the start of the printing
problems only coincided with my upgrade to FC6, and was not caused by it, so my
bad for the mis-diagnosis.

However, this also means that evince's print capabilities seem to need more
thorough error diagnostics. If it happens that a printer shows on the printer
list and the user cannot contact it, it would be very useful to see the actual
reason why this happens.  At least a response from CUPS daemon, printed
somewhere in clear text would be more than helpful.
Comment 17 Tim Waugh 2006-12-11 06:21:49 EST
Nothing evince can do about this; it's all internal to the GTK+ print dialog. 
Changing component and reassigning.
Comment 18 Tim Waugh 2006-12-13 06:41:15 EST
Changing summary.
Comment 19 Bug Zapper 2008-04-04 00:40:33 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 20 Bug Zapper 2008-05-06 12:49:07 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.