Bug 215487 - Canon IR2020i department printer incorrectly interprets page size
Canon IR2020i department printer incorrectly interprets page size
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: foomatic (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-14 06:28 EST by Răzvan Sandu
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-12 09:22:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Răzvan Sandu 2006-11-14 06:28:07 EST
Description of problem:

We own a Canon IR2020i printer.

As instructed on http://www.linuxprinting.org, this is configured on (a stock) 
FC6 as Generic PCL6/ PCL XL foomatic Printer using the plxmono driver.

Communication is done through the network, as a Jetdirect Device on port 9100
.
Configuration is done through Fedora supplied wizard (in Gnome, menu System ->
Administration -> Printing).

Paper format is A4, in Tray1.

Cups print test page (A4) prints OK.

However, when trying to print from another application (Mozilla Firefox,
OpenOffice.org, etc), printer signals a LTR (Letter) job, which "locks" the
printer because it has no Letter paper in it. There is no software or hardware
option to "explicitly "resize" the output job from Letter to A4.

Version-Release number of selected component (if applicable):
foomatic-3.0.2-39.1.fc6
cups-1.2.5-2.fc6.8

How reproducible:
Anytime - try to print any job (except the provided print page) in the above
conditions.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Printer "locks", waiting for Letter paper.

Expected results:
Printer should work with A4 paper, from any application, as defined in driver's
software options.
Printer should be supported directly through foomatic's list of supported models.

Additional info:
Comment 1 Tim Waugh 2006-11-14 12:16:39 EST
When you print from Firefox, for example, are the print settings in Firefox set
to print A4 or Letter?

PPDs can only provide a default for applications to use; applications may
override the page size.
Comment 2 Răzvan Sandu 2006-11-15 06:31:31 EST
Hello and thanks,

No, all applications are set on A4, as long such an option is available in the
application itself (Firefox, OpenOffice.org, etc.)

Since Letter paper format is rarely available in Romania (almost unknown), all
aplications are set on A4 by default. That means one must change from Letter
(default setting in all US-style programs) to A4 and make this change persistent.


Regards,
Razvan
Comment 3 Răzvan Sandu 2006-11-21 14:32:11 EST
Hello again,


It seems this printer model has some hardware/firmware oddity: the described
problem seems to occur even in Windows, with the Canon original drivers, from
time to time (we use it daily for relatively high-volume printing).

Since I don't have neither connections at Canon, nor very much knowledge about
writing drivers on hardware specifications, please, could someone more
knowledgeable verify this with them? IMHO, this printer model *worths* the
effort, since it is a complex, good quality department printer & scanner and
works smoothly otherwise...


Regards,
Razvan

Comment 4 Răzvan Sandu 2006-11-21 14:45:50 EST
Here it is the software Canon gives for Linux, at their site, for the iR2020i
printer (probably not free):


SQue 9.2.2 in text mode
http://software.canon-europe.com/files/soft25086/software/96b1enx.zip

SQue 9.2.2 in X mode
http://software.canon-europe.com/files/soft25111/software/g6b2enx.zip



Razvan
Comment 5 Tim Waugh 2006-12-12 09:22:58 EST
Without access to the hardware in question, there's not much that can be done. :-/

Sounds like it's something Canon needs to fix themselves.

Note You need to log in before you can comment on or make changes to this bug.