Bug 215505 - DM multipath devices are not created - for the luns with dev_t minor numbers > 256
Summary: DM multipath devices are not created - for the luns with dev_t minor numbers ...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
(Show other bugs)
Version: 4.4
Hardware: All Linux
medium
high
Target Milestone: ---
: ---
Assignee: Ben Marzinski
QA Contact: Corey Marthaler
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 217972
TreeView+ depends on / blocked
 
Reported: 2006-11-14 13:40 UTC by Stephen Reilly
Modified: 2010-01-12 02:27 UTC (History)
15 users (show)

Fixed In Version: RHEA-2007-0256
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 17:46:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2007:0256 normal SHIPPED_LIVE device-mapper-multipath enhancement update 2007-05-01 17:35:42 UTC

Description Stephen Reilly 2006-11-14 13:40:54 UTC
DM devices are not being created for the Luns with minor numbers greater than
256 when mpath_prio_alua is used as path_prio_callout routine.

How reproducible:
=======================
Always

Steps to Reproduce:
=======================
1.      present larger set of LUNs (with more than 2 HBAs in the host and
having exposed paths from each HBA for the Lun) from HSV111 array to the host
2.      Following are the Parameters in /etc/mutilapth.conf for HSV210 Devices
        device {
                vendor                  "HP*"
                product                 "HSV111"
                path_grouping_policy    group_by_prio
                prio_callout            "/sbin/mpath_prio_alua %d"
                getuid_callout          "/sbin/scsi_id -g -u -s /block/%n"
                path_checker            tur
                path_selector           "round-robin 0"
                hardware_handler        "0"
                failback                immediate
                rr_weight               priorities
                no_path_retry           60
                rr_min_io               1000
                product_blacklist       LUN_Z
        } 
4.      Reboot the system

Actual Results:
=========================
DM devices are not created for HSV111 Luns for the paths with dev_t minor
numbers greater than 256


Initial investigation and analysis:
====================================

The issue seems to be b'cos of mpath_prio_alua and its argument as %d. 
With "multipath -v3" output, the messages shows that, "mpath_prio_alua" with "%
d" as argument return -1 for the devices with dev_t minor numbers greater than 
256.
For Example, the devices with dev_t maj:min numbers as 71:256, 68:384 reports
these error, and the multipath devices are not getting vreated for those Luns. 

But, "mpath_prio_alua" with "%n" for the same devices returns the valid
priority for those devices and the multipath devices are succesfully created.


"mpath_prio_alua %d" and "mpath_prio_alua %n" behave differently with the later
one works well with all devices and the earlier one doesnt work with the
devices having minor number greater than 256.

Comment 3 Ben Marzinski 2006-12-04 16:28:27 UTC
Pulled in the upstream patch to fix this issue.

Comment 6 Red Hat Bugzilla 2007-05-01 17:46:06 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2007-0256.html



Note You need to log in before you can comment on or make changes to this bug.