Bug 215539 - Unpredictable freeze of mouse and/or keyboard on amd64 x2 nvidia chipset (Dell E521)
Unpredictable freeze of mouse and/or keyboard on amd64 x2 nvidia chipset (Del...
Status: CLOSED DUPLICATE of bug 201445
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-14 11:09 EST by James Martin
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-13 17:31:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg configuration file (1.90 KB, application/octet-stream)
2006-11-20 09:49 EST, James Martin
no flags Details
xorg log file (23.17 KB, text/plain)
2006-11-20 09:50 EST, James Martin
no flags Details

  None (edit)
Description James Martin 2006-11-14 11:09:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.8) Gecko/20061107 Fedora/1.5.0.8-1.fc6 Firefox/1.5.0.8

Description of problem:
The mouse will unpredictably lock up while using X (and by some reports it locks up during console use).  Running KDE here.  It will lock up at varying intervals, but all seem to be less than one hour.  The only method to unlock the mouse is to remove it from the USB port briefly and re-insert it.  This is a Dual Core Athlon 5000+.

This does not seem to be specific to Fedora, but does seem to be specific to AMD64 Dual Cores and the Nvidia Chipset.. There's a thread on the Ubuntu forums with the same problem:  

https://launchpad.net/distros/ubuntu/+source/linux-source-2.6.17/+bug/67734

and also in FreeBSD:

http://72.14.209.104/search?q=cache:Bg2IaQ8xIa8J:www.mail-archive.com/freebsd-usb%40freebsd.org/msg00938.html+dell+e521+mouse+freeze&hl=en&lr=&client=firefox-a&strip=1

Some seem to claim by hooking mouse through external hub solves the problem, but that doesn't seem acceptable.


Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.1.1-47.fc6

How reproducible:
Always


Steps to Reproduce:
1. Use mouse for no longer than an hour. (most likely 15 minutes or so)
2. Watch mouse lock.


Actual Results:
Mouse locks up.

Expected Results:
Mouse shouldn't lock up.

Additional info:
00:00.0 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.1 RAM memory: nVidia Corporation C51 Memory Controller 0 (rev a2)
00:00.2 RAM memory: nVidia Corporation C51 Memory Controller 1 (rev a2)
00:00.3 RAM memory: nVidia Corporation C51 Memory Controller 5 (rev a2)
00:00.4 RAM memory: nVidia Corporation C51 Memory Controller 4 (rev a2)
00:00.5 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.6 RAM memory: nVidia Corporation C51 Memory Controller 3 (rev a2)
00:00.7 RAM memory: nVidia Corporation C51 Memory Controller 2 (rev a2)
00:02.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:03.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:04.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:09.0 RAM memory: nVidia Corporation MCP51 Host Bridge (rev a2)
00:0a.0 ISA bridge: nVidia Corporation MCP51 LPC Bridge (rev a3)
00:0a.1 SMBus: nVidia Corporation MCP51 SMBus (rev a3)
00:0a.2 RAM memory: nVidia Corporation MCP51 Memory Controller 0 (rev a3)
00:0b.0 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0b.1 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0e.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev a1)
00:0f.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev a1)
00:10.0 PCI bridge: nVidia Corporation MCP51 PCI Bridge (rev a2)
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
03:00.0 VGA compatible controller: nVidia Corporation GeForce 7300 LE (rev a1)
04:07.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
04:08.0 FireWire (IEEE 1394): Agere Systems FW323 (rev 61)


On kernel 2.6.18-1.2849.fc6
Comment 1 Matěj Cepl 2006-11-15 05:37:14 EST
Thanks for the bug report.  We have reviewed the information you
have provided above, and there is some additional information we
require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X
server log file (/var/log/Xorg.*.log) to the bug report as individual
uncompressed file attachments using the bugzilla file attachment link
below.

We will review this issue again once you've had a chance to attach
this information.

Thanks in advance.
Comment 2 James Martin 2006-11-20 09:49:23 EST
Created attachment 141652 [details]
xorg configuration file

Yes I'm using proprietary nvidia drivers, but the aforementioned bug occurs
even with the native xorg drivers.
Comment 3 James Martin 2006-11-20 09:50:58 EST
Created attachment 141653 [details]
xorg log file
Comment 4 Guy Streeter 2006-11-22 12:06:46 EST
I also have an AMD64 X2 ona n ASUS mainboard with onboard NVidia Geforece 6.
My mouse will keep moving the pointer, but its button clicks stop doing anything.
This was happening before I started using the nvidia proprietary drivers, and
still happens while using them.

These incidents are assoicated with these messages in the xorg.0.log file:

(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(II) No APM support in BIOS or kernel
(II) NVIDIA(0): Setting mode "nvidia-auto-select"
(II) <default pointer>: ps2EnableDataReporting: succeeded
(II) 3rd Button detected: disabling emulate3Button
Comment 5 Luis Felipe Marzagao 2006-12-04 21:57:16 EST
Hello. This bug is *serious* because it happens with all nforce 430 chipsets.
The problem seems to be with that specifc chipset.

This bug is a duplicate of:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=201445


Here is a lot of info about this issue:

http://forums.fedoraforum.org/showthread.php?t=136879&page=1&pp=15

https://launchpad.net/distros/ubuntu/+source/linux-source-2.6.17/+bug/67734

http://forums.us.dell.com/supportforums/board/message?board.id=sw_other&message.id=54328&view=by_date_ascending&page=1

I have a Dell Dimension C521 (AMD processor and the nforce 430 chipset) with the
same problem (mouse freezes often). The only way to work with the mouse is to
unplug and plug it again.

I´d be happy to provide any info from my machine to help solve this problem.

Cheers
Comment 6 Matěj Cepl 2006-12-13 17:31:25 EST

*** This bug has been marked as a duplicate of 201445 ***
Comment 7 Erik Bussink 2006-12-15 05:04:33 EST
Just a head's up, I'm seeing the same issue on RHEL5 Beta 2 with a Sager 9750 
(Clevo D900K) laptop with an AMD X2 4800+, but this laptop doesn't have a 
nvidia chipset (it uses a VIA K8T890CE).

Note You need to log in before you can comment on or make changes to this bug.