Bug 215545 - The kdump finishes properly but the vmcore is not complete.
Summary: The kdump finishes properly but the vmcore is not complete.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Neil Horman
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-14 16:30 UTC by Akira Imamura
Modified: 2018-10-19 19:10 UTC (History)
3 users (show)

Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-13 17:27:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This patch is based on -131.el5 and can fix this problem. (813 bytes, patch)
2006-11-14 16:30 UTC, Akira Imamura
no flags Details | Diff

Description Akira Imamura 2006-11-14 16:30:31 UTC
Description of problem:
The kdump seems to complete properly but the vmcore created by kdump
is incomplete (the file name is vmcore-incomplete). I think the cause of
this problem is that file caches won't be written to the disk before kdump
reboots system. The kdump can create the vmcore completely by running
"umount" before running "reboot".


Version-Release number of selected component (if applicable):
kexec-tools-1.101-131.el5

How reproducible:
This problem occurs easier in the case that the reserved
memory for 2nd kernel is larger.


Steps to Reproduce:
1. Run "service kdump start".
2. Make system panic.
3. See a created vmcore file after rebooting.
  
Actual results:
-r-------- 1 root root 15943680000 Nov 13 20:51 vmcore-incomplete

Expected results:
-r--------    1 root     0       16341865252 Nov 13 20:51 vmcore



Additional info:

Comment 1 Akira Imamura 2006-11-14 16:30:32 UTC
Created attachment 141162 [details]
This patch is based on -131.el5 and can fix this problem.

Comment 2 Neil Horman 2006-11-14 16:55:17 UTC
you're patch is wrong, you still need that unmount in case something goes wrong
during the copy.  you don't want to leave a filesystem mounted if you switchroot
to the rootfs to run init.

I'll fix this and the nfs case shortly.

Comment 3 Neil Horman 2006-11-14 17:31:20 UTC
fixed in -132.el5. thanks

Comment 6 Jay Turner 2007-02-13 17:27:21 UTC
Closing out.


Note You need to log in before you can comment on or make changes to this bug.