Bug 215553 - Extraneous error message: refused unmount request / not exported
Extraneous error message: refused unmount request / not exported
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
6
All Linux
medium Severity low
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-14 12:04 EST by Orion Poplawski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.0.10-5.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-15 15:39:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bzip2 thethereal -w output (4.67 KB, application/octet-stream)
2006-11-15 14:15 EST, Orion Poplawski
no flags Details
Purposed patch (2.21 KB, patch)
2006-12-11 15:01 EST, Steve Dickson
no flags Details | Diff

  None (edit)
Description Orion Poplawski 2006-11-14 12:04:59 EST
Description of problem:

Since upgrading some of our machines to FC6, I'm noticing the following error
messages on our NFS servers (FC5 and FC6) when an FC6 client unmounts a NFSv4 mount:

Nov 14 09:35:16 saga mountd[3128]: refused unmount request from
cynosure.cora.nwra.com for /data1 (/): not exported

Everything seems to work okay though.

Version-Release number of selected component (if applicable):
nfs-utils-1.0.10-1.fc6

How reproducible:
everytime

Steps to Reproduce:
1. mount NFSv4 directory
2. umount it
Comment 1 Steve Dickson 2006-11-15 14:01:58 EST
hmm.. this is a bit odd... would it be possible to pust what your exports look
like as well as a bzip2 binary tethereal network trace? Something similar to:
    tethereal -w /tmp/data.pcap host <servername> 
Comment 2 Orion Poplawski 2006-11-15 14:15:54 EST
Created attachment 141297 [details]
bzip2 thethereal -w output

/etc/exports:

/export 	*.cora.nwra.com(rw,sync,fsid=0)
/export/turb1	*.cora.nwra.com(rw,sync,nohide)
/export/turb2	*.cora.nwra.com(rw,sync,nohide)
/export/turb3	*.cora.nwra.com(rw,sync,nohide)
/export/timed2	*.cora.nwra.com(rw,sync,nohide)
Comment 3 Steve Dickson 2006-11-29 11:14:31 EST
What is really bizare here is that NFSv4 does not use or need mountd to
mount or umount so why mountd is involved at all is pretty mind bending...

Are you sure a v2 or v3 mount is happening after the v4 umount? 
Comment 4 Orion Poplawski 2006-11-29 11:24:00 EST
This is all I'm doing:

[root@cynosure ~]# mount -t nfs4 saga:/data1 /mnt
[root@cynosure ~]# umount /mnt

Nov 29 09:22:04 saga mountd[3860]: refused unmount request from
cynosure.cora.nwra.com for /data1 (/): not exported

/etc/exports:
/export         *.cora.nwra.com(rw,sync,fsid=0,no_root_squash)
/export/data1   *.cora.nwra.com(rw,sync,nohide,no_root_squash)
/export/amanda  *.cora.nwra.com(rw,async,nohide,no_root_squash)
/export/backup1 *.cora.nwra.com(rw,async,nohide,no_root_squash,insecure)
/export/backup2 *.cora.nwra.com(rw,async,nohide,no_root_squash)

No other mount traffic.
Comment 5 Steve Dickson 2006-12-11 14:01:21 EST
what is the output of the 'rpcinfo -p server' command?
Comment 6 Orion Poplawski 2006-12-11 14:08:12 EST
# rpcinfo -p saga
   program vers proto   port
    100000    2   tcp    111  portmapper
    100000    2   udp    111  portmapper
    100024    1   udp    792  status
    100024    1   tcp    795  status
    100011    1   udp    831  rquotad
    100011    2   udp    831  rquotad
    100011    1   tcp    846  rquotad
    100011    2   tcp    846  rquotad
    100003    2   udp   2049  nfs
    100003    3   udp   2049  nfs
    100003    4   udp   2049  nfs
    100003    2   tcp   2049  nfs
    100003    3   tcp   2049  nfs
    100003    4   tcp   2049  nfs
    100021    1   udp  32768  nlockmgr
    100021    3   udp  32768  nlockmgr
    100021    4   udp  32768  nlockmgr
    100021    1   tcp  53745  nlockmgr
    100021    3   tcp  53745  nlockmgr
    100021    4   tcp  53745  nlockmgr
    100005    1   udp    854  mountd
    100005    1   tcp    866  mountd
    100005    2   udp    854  mountd
    100005    2   tcp    866  mountd
    100005    3   udp    854  mountd
    100005    3   tcp    866  mountd
    100007    2   udp    958  ypbind
    100007    1   udp    958  ypbind
    100007    2   tcp    961  ypbind
    100007    1   tcp    961  ypbind
Comment 7 Steve Dickson 2006-12-11 15:01:44 EST
Created attachment 143319 [details]
Purposed patch 

n  turns out that the umount code was rpc pinging the remote
rpc.mountd even on NFSv4 mounts which is definitely wrong...
This patch fixes the problem....

Please let me know if you need an updated nfs-utils rpm..
Comment 8 Orion Poplawski 2006-12-11 22:50:57 EST
That does appear to take care of it.  I'll install on my other FC6 machines
tomorrow and test it out further.  Thanks!
Comment 9 Steve Dickson 2006-12-13 10:11:19 EST
Fixed in nfs-utils-1.0.10-5.fc6
Comment 10 Orion Poplawski 2006-12-15 15:39:33 EST
Confirmed.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.