Bug 215583 - Unable to input Japanese characters to firefox.i386 in x86_64 system
Unable to input Japanese characters to firefox.i386 in x86_64 system
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
6
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jens Petersen
:
Depends On:
Blocks: 215750
  Show dependency treegraph
 
Reported: 2006-11-14 13:53 EST by Jun'ichi Nomura (Red Hat)
Modified: 2013-04-02 19:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-04 23:29:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/root/install.log (51.59 KB, text/plain)
2006-11-28 09:42 EST, Jun'ichi Nomura (Red Hat)
no flags Details

  None (edit)
Description Jun'ichi Nomura (Red Hat) 2006-11-14 13:53:38 EST
Description of problem:
In a system FC6(x86_64) is installed, when I press hot-key
to start input Japanese characters, there are no communication
with SCIM appearing.
Copy-and-paste from other window is possible.
SCIM works on other programs and firefox.x86_64.

Version-Release number of selected component (if applicable):
firefox.i386 1.5.0.8-1.fc6 (i386)
scim 1.4.4-35.fc6

How reproducible:
Always

Steps to Reproduce:
1. Install FC6(x86_64)
2. Install firefox.i386
3. Uninstall firefox.x86_64
4. Start firefox
5. Try to invoke SCIM for Japanese input
  
Actual results:
It doesn't switch to Japanese input mode.

Expected results:
It switches to Japanese input mode.

Additional info:
The combination of firefox.i386 and scim.x86_64 worked
in FC5.
Comment 1 Jens Petersen 2006-11-14 21:17:21 EST
What is your output of

  rpm -qa --qf "%{name}-%{version}-%{release}.%{arch}\n" scim\* | sort

please?

My guess would be that you have scim-bridge-gtk.x86_64 installed
but not scim-bridge-gtk.i386.

Need to address this multilib robustness issue for fc7...
Comment 2 Jun'ichi Nomura (Red Hat) 2006-11-15 09:38:45 EST
Thanks, it solved the problem!

The output of the rpm command was:
scim-1.4.4-35.fc6.x86_64
scim-anthy-1.2.0-3.fc6.x86_64
scim-libs-1.4.4-35.fc6.i386
scim-libs-1.4.4-35.fc6.x86_64
scim-qtimm-0.9.4-5.i386
scim-qtimm-0.9.4-5.x86_64

Then, I installed scim-bridge and scim-bridge-gtk:
scim-bridge-0.4.7-1.fc6.x86_64
scim-bridge-gtk-0.4.7-1.fc6.i386

and now I can input Japanese to firefox.
Comment 3 Jens Petersen 2006-11-15 19:32:34 EST
Just installing scim-bridge-gtk.i386 is not going to be good:
you want to install scim-bridge-gtk.x86_64 as well.

This is strange though, since you had both scim-libs.i386 and
scim-libs.x86_64 installed, input in firefox.i386 should work just fine
without scim-bridge too.
Comment 4 Jens Petersen 2006-11-28 01:46:52 EST
Could you please attach install.log?
Comment 5 Jun'ichi Nomura (Red Hat) 2006-11-28 09:42:01 EST
Created attachment 142291 [details]
/root/install.log

Is this a file you requested?
If any other files are needed, please let me know.
Comment 6 Jens Petersen 2006-11-28 19:42:03 EST
Okay it seems you installed without Japanese support.

Do you remember how you installed Japanese support after installation?
Comment 7 Jun'ichi Nomura (Red Hat) 2006-11-29 10:03:37 EST
Yes, you are right. I remember I did install Japanese support later.

I'm not quite sure about the exact operation but I found
the following command line in my history file:
yum install fonts-japanese openoffice.org-langpack-ja_JP man-pages-ja anthy
scim-anthy scim-qtimm

And yum.log looks like this:
# egrep -i "scim|anthy|japa|jp" yum.log 
Oct 30 10:12:34 Installed: scim-libs.x86_64 1.4.4-35.fc6
Oct 30 10:12:36 Installed: anthy.x86_64 7900-2.fc6
Oct 30 10:12:37 Installed: scim-libs.i386 1.4.4-35.fc6
Oct 30 10:12:39 Installed: scim.x86_64 1.4.4-35.fc6
Oct 30 10:12:52 Installed: fonts-japanese.noarch 0.20061016-1.fc6
Oct 30 10:12:53 Installed: scim-anthy.x86_64 1.2.0-3.fc6
Oct 30 10:12:55 Installed: anthy.i386 7900-2.fc6
Oct 30 10:12:56 Installed: scim-qtimm.i386 0.9.4-5
Oct 30 10:12:58 Installed: scim-qtimm.x86_64 0.9.4-5
Oct 30 10:13:02 Installed: openoffice.org-langpack-ja_JP.x86_64 1:2.0.4-5.3
Nov 14 10:46:47 更新されました: openoffice.org-langpack-ja_JP.x86_64 2.0.4-5.5.3
Nov 15 09:19:59 Installed: scim-bridge.x86_64 0.4.7-1.fc6
Nov 15 09:19:59 Installed: scim-bridge-gtk.i386 0.4.7-1.fc6
Nov 16 11:07:42 Installed: scim-bridge-gtk.x86_64 0.4.7-1.fc6
Nov 20 10:35:34 更新されました: scim-anthy.x86_64 1.2.2-1.fc6

"更新されました" means "updated".

And in sysconfig:
# cat /etc/sysconfig/i18n 
LANG="ja_JP.UTF-8"
SYSFONT="lat0-sun16"
Comment 8 Jens Petersen 2006-11-29 21:21:38 EST
Thanks for the additional information, which also agrees with comment 2.
(BTW an easier way to install Japanese support in the future is "yum
groupinstall japanese-support" (or using pirut -> Languages).)

I did a fresh FC6 x86_64 test install here and reproduced the problem:

1. ja install of fc6/x86_64
2. rpm -e firefox.x86_64
3. GTK_IM_MODULE=scim firefox
4. Ctrl-Space

and one is in the English/European IME and Japanese (anthy) is not listed
in the scim menu.  It works fine with scim-bridge as you noted.
Comment 9 Jens Petersen 2006-11-30 00:02:48 EST
Thanks for reporting this. I found out the cause: this was caused
by moving all the scim dl modules to the main scim package even though
the gtk immodule actually needs several of them.

Luckily scim-bridge is not affected since its gtkimm does not link
against libscim.

This will be fixed in a future FC6 update.
Comment 10 Jens Petersen 2006-12-10 23:24:11 EST
This should be fixed in scim-1.4.4-36.fc6.

Note You need to log in before you can comment on or make changes to this bug.