Bug 215624 - Basic "hello-world" with systemtap doesn't work
Basic "hello-world" with systemtap doesn't work
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: systemtap (Show other bugs)
rawhide
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Frank Ch. Eigler
Radek Bíba
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2006-11-14 16:36 EST by Tony Luck
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 0.5.10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-14 18:39:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tony Luck 2006-11-14 16:36:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; InfoPath.1)

Description of problem:
The systemtap tutorial by Frank Eigler starts with:

# cat hello-world.stp
probe begin
{
   print("hello world\n")
   exit()
}
# stap hello-world.stp

This fails.  Running with "-v" the first problem is that the generated .c file includes linux/config.h, which has been obsoleted in 2.6.18.  Workaround: make an empty config.h file.

Second problem: generated module will not load due to missing symbol. Dmesg(1) reports:

stap_9360: Unknown symbol kallsyms_lookup_name

Checking against the git log ... the export of this symbol was dropped when a new method was added to the kernel for symbol to address resolution.

Version-Release number of selected component (if applicable):
systemtap-0.5.9-1.fc6

How reproducible:
Always


Steps to Reproduce:
1.See
2.the
3.description

Actual Results:
Module is built (once I created empty config.h file) but will not load.

Expected Results:
Module should have loaded and printed "hello world".

Additional info:
Comment 1 Tony Luck 2006-11-14 16:45:45 EST
Prarit said "be sure to file them against the devel branch of Fedora Core.  
Also, add "fedora-ia64" to the "blocks" field of the BZ".  Hope this is now 
right.
Comment 2 Frank Ch. Eigler 2006-11-14 18:39:37 EST
Fedora rawhide already contains a newer 0.5.10 version that corrects this problem.
Comment 3 Tony Luck 2006-11-15 18:29:34 EST
Thanks ... 0.5.10 does indeed fix this.

Note You need to log in before you can comment on or make changes to this bug.