Bug 215632 - ncview app-defaults not found
ncview app-defaults not found
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ncview (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ed Hill
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-14 17:47 EST by David Nečas
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-24 23:28:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Nečas 2006-11-14 17:47:30 EST
Description of problem:
ncview cannot find its app-defaults file located in /usr/lib64/X11/app-defaults/
and refuses to run.


Version-Release number of selected component (if applicable):
ncview-1.92e-8.fc6


How reproducible:
Always.


Steps to Reproduce:
1. ncview gxsm-demo-Si100-4deg.nc

 
Actual results:
Ncview 1.92e David W. Pierce  13 Aug 2003
http://meteora.ucsd.edu:80/~pierce/ncview_home_page.html
Copyright (C) 1993 through 2003, David W. Pierce
Ncview comes with ABSOLUTELY NO WARRANTY; for details type `ncview -w'.
This is free software; type `ncview -c' for redistribution details.

Error: I cannot find the proper app-defaults file, which
should be named `Ncview'.  I need an app-defaults file
for ncview version 1.91, but have found version 0.00.
(Note: a found version of 0.00 means either no
app-defaults file was found at all, or a pre-version 1.60
file was found.)
To fix this, you must put file `Ncview'
(NOT the executable, which is named `ncview') either in 
your local $XAPPLRESDIR directory, in the global directory
/usr/local/lib/X11/app-defaults, or add it to your own
.Xdefaults file.

(and program terminates)


Expected results:
It runs and shows the given file.


Additional info:
This problem might be visible only on x86_64 due to lib -> lib64 (haven't tried
i386), but the primary cause is that the app-defaults file is not installed into
/usr/share/X11/app-defaults where it belongs.  Symlinking it there fixes the
problem.
Comment 1 Ed Hill 2006-11-15 01:25:41 EST
Hi David,

Thanks for the bug report!  I've moved the file to as you suggest.  
Please try the new versions (should be available soon-ish) and if its 
OK then let me know and we can close this bug.
Comment 2 Ed Hill 2006-12-24 23:28:09 EST
Hi David, I moved the file, confirmed that it works for me, and am 
closing this bug.  If you are still having problems then please 
re-open it.

Note You need to log in before you can comment on or make changes to this bug.