Bug 215638 - KeyError when trying to create a fully-virt domain with virt-manager
Summary: KeyError when trying to create a fully-virt domain with virt-manager
Status: CLOSED DUPLICATE of bug 220036
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Daniel Berrange
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-14 23:01 UTC by Chris Lalancette
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-05 14:07:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Lalancette 2006-11-14 23:01:17 UTC
Description of problem:
I tried to create a fully-virtualized domain on x86_64 Xen (kernel
2.6.18-1.2747.el5xen).  After getting to the last screen and clicking on
"Finish", the "Creating Domain" dialog comes up for a few seconds, and then
disappears and drops me back at the last dialog.  On the console, I get the
following message:

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 388, in finish
    vm = self.connection.get_vm(guest.uuid)
  File "/usr/share/virt-manager/virtManager/connection.py", line 60, in get_vm
    return self.vms[uuid]
KeyError: 'c845d431-23e6-60b7-7186-7cd2fdfdb392'

It would seem that connection.py is trying to access an array element that isn't
there, but since my knowledge of python is so limited, I won't speculate further
than that.

Version-Release number of selected component (if applicable):
virt-manager 0.2.5-1.el5

Comment 1 Daniel Berrange 2007-01-05 14:07:37 UTC

*** This bug has been marked as a duplicate of 220036 ***


Note You need to log in before you can comment on or make changes to this bug.