Bug 215644 - Request to Enable Iloko Locale
Request to Enable Iloko Locale
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-14 18:42 EST by Joseph S. Maza
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-28 12:45:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda localization resources for Iloko locale (100%) (223.04 KB, application/octet-stream)
2006-11-24 22:56 EST, Joseph S. Maza
no flags Details

  None (edit)
Description Joseph S. Maza 2006-11-14 18:42:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

Description of problem:
This a request the Iloko Locale -
Language codes: ilo, ilo-PH

English Name: Ilocano, Iloko (Preferred)

Native Name: Iloko

Keyboard: U.S. English QWERTY 

Code Page: Iloko is written in the Latin alphabet. The US codepage should be suitable: ANSI, 1250

Time Zone: UTC +8 (PHT)

Ethnologue: http://www.ethnologue.com/show_language.asp?code=ilo

Version-Release number of selected component (if applicable):
N/A

How reproducible:
Always


Steps to Reproduce:
No Repro steps

Actual Results:


Expected Results:


Additional info:
Comment 1 Joseph S. Maza 2006-11-14 18:44:56 EST
Please, let me know if there is any other information that you may need. Thanks.
Comment 2 Jeremy Katz 2006-11-16 15:09:22 EST
To add support, there needs to be at least 90% translation coverage.  See
http://fedoraproject.org/wiki/L10N
Comment 3 Joseph S. Maza 2006-11-16 18:02:04 EST
I did not know of the 90% coverage criterion since there was not mentioning of 
the criteria on the page that was cited.

I've already localized the files for autorun and about 50% for anaconda. I am 
currently soliciting other speakers of the language to participate. 

Here are a few more questions because I would appreciate some clarification 
before I embark on localizing anything any further or soliciting the assitance 
of others.

1) What constitutes 90%? How is that supposed to be proven? Does that mean both 
UI text AND Documentation? Or, just UI?

2) How can I test the locale if it isn't even enabled on the system?

This might see irrelevant, but I noticed that Tagalog, another Filipino 
language, is "available" in Fedora Core 6, yet I don't see any files in CVS for 
the locale (tl.po nor tl-PH.po). And, when I started to use the locale in FC6, 
NOTHING was localized. 
So, question #3...

3) Was Tagalog enabled before this criterion was in effect?
Comment 4 Joseph S. Maza 2006-11-24 22:56:25 EST
Created attachment 142102 [details]
anaconda localization resources for Iloko locale (100%)

anaconda localization resources for Iloko locale (100%)
Comment 5 Joseph S. Maza 2006-11-24 23:03:53 EST
Comment on attachment 142102 [details]
anaconda localization resources for Iloko locale (100%)

I have attached the resourced file for anaconda to fulfill the 90% localization
criterion.
Comment 6 Joseph S. Maza 2006-11-24 23:05:36 EST
I was told later that the file needed to be attached and contain over 90% of 
localization. Next time would that be better comminicated for those who wish to 
add a locale not included in the latest release.
Comment 7 Jeremy Katz 2006-11-28 12:45:49 EST
Great, thanks -- added to lang-table and so will show up in the next build

Note You need to log in before you can comment on or make changes to this bug.