Bug 215663 - Can't browse windows network immediately after logon
Can't browse windows network immediately after logon
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-vfs (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-14 22:00 EST by Marcos Martins da Silva
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-18 02:26:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my current samba environment (3.45 KB, text/plain)
2006-11-15 10:15 EST, Marcos Martins da Silva
no flags Details

  None (edit)
Description Marcos Martins da Silva 2006-11-14 22:00:33 EST
Description of problem:
I Can't browse windows network immediately after logon, just about 5 minutes later. 

Version-Release number of selected component (if applicable):
All system is updated to most current rpms with yum (11/15/2006)

How reproducible:


Steps to Reproduce:
1. Just after logon, open nautilus and go network
2. Nautilus shows a "windows network" icon
3. If you click on that icon I can't see no servers
4. open terminal and "tail -f /var/log/messages
5. Past about 5 minutes I get a message from nmbd sayng my computer is a local
master browser.
6. Since this message I can browse the network and see all windows and samba
servers and shares.
  
Actual results:
I can only browse my network after nmbd forces an election and my machine
becomes a local master browser

Expected results:
I should be able to browse windows network as soon I logon

Additional info:
If I use smbclient -L on console I can see all servers and shares even before I
can browse on nautilus
My machine is connected to a windows 2000 network (AD). SELinux is disabled.I
have set iptables to accept netbios traffic (137-139 and 445 ports).
Authentication and user information (authentication dialog) are set to use
winbind and smb. Winbind and samba are running OK. My machine is joined to
domain (ads). I edited gdm and login files on /etc/pam.d to include
pam_mkhomedir so any windows user can logon on my machine and homedir is
automatically created.
Comment 1 Alexander Larsson 2006-11-15 03:17:05 EST
Is a wins server setup in smb.conf?

Comment 2 Marcos Martins da Silva 2006-11-15 10:13:44 EST
Hi alexl, thank you for your interest. Yes, there is a wins server set in my
smb.conf and BTW, the wins server is a Linux/Samba box and it works for all my
network (about 1500 machines).
I'm creating an attachment (environment.txt) with a fragment of
/var/log/messages (seven last lines), /etc/samba.smb.conf, /etc/nsswitch.conf,
/etc/pam.d/login, /etc/pam.d/gdm,/etc/sysconfig/authconfig, /etc/sysconfig/samba.
I have supressed almost all comments from these files to ease reading. Just a
few comments about the attached file:
1. I just turn on the computer and it was not necessary to login and six minutes
after the last boot message, my box has become a local master browser. I had
previously and incorrectly assumed it was after login just because the normal
practice is login as soon as prompt/gdm asks for. This time I boot the machine
and returned about 30 minutes later (see the fragment of /var/log/messages)
2. My smb.conf is really configured to start local browser elections, but if I
had set it not to start the elections, network browsing is not possible even 20
minutes later. Even smbtree does not retrieve anything but smbclient works
normally and I can access all my windows/samba shares on console. Nautilus and
smbtree work only if my machine becomes a local master browser.
3.On /etc/nsswitch.conf I had to comment out some lines with winbind option in
order to autofs works. During boot, autofs service is started long before winbind.
4. I have changed login and gdm files in /etc/pam.d just to get automatic
creation of homedirs for network (AD authenticated users).
Comment 3 Marcos Martins da Silva 2006-11-15 10:15:20 EST
Created attachment 141268 [details]
my current samba environment
Comment 4 Marcos Martins da Silva 2006-11-18 02:26:18 EST
I solved the problem of 5-6 minutes delay for browsing setting preferred master
as yes on smb.conf. That forces election immediately after smbd and nmbd start.
I think this bug may be marked as solved or notabug. Thank you!

Note You need to log in before you can comment on or make changes to this bug.