Bug 215669 - Define LIBDIR, BINDIR, etc. in Makefile
Define LIBDIR, BINDIR, etc. in Makefile
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Directory Server (Show other bugs)
1.0.2
All All
medium Severity medium
: ---
: ---
Assigned To: Rich Megginson
Viktor Ashirov
:
Depends On:
Blocks: 152373 240316 FDS1.1.0
  Show dependency treegraph
 
Reported: 2006-11-14 23:08 EST by Rich Megginson
Modified: 2015-12-07 12:17 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 12:17:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
diffs (3.49 KB, patch)
2006-11-14 23:08 EST, Rich Megginson
no flags Details | Diff
cvs commit log (1.49 KB, text/plain)
2006-11-15 12:18 EST, Rich Megginson
no flags Details

  None (edit)
Description Rich Megginson 2006-11-14 23:08:10 EST
Instead of hard-coding LIBDIR, BINDIR et. al. in create_instance.h, these should
be defined during make.  We can't define them during configure (with AC_DEFINE)
because the values of libdir, bindir, et. al. depend on $prefix and $exec_prefix
which may be set at make time.
Comment 1 Rich Megginson 2006-11-14 23:08:10 EST
Created attachment 141220 [details]
diffs
Comment 2 Rich Megginson 2006-11-15 12:18:18 EST
Created attachment 141286 [details]
cvs commit log

Reviewed by: nkinder (Thanks!)
Branch: HEAD
Fix Description: The paths LIBDIR, BINDIR, et. al. are #define'd in
create_instance.h to hard coded values.  We should be able to set these values
in configure and override the built in values.	We can't simply set them via
AC_DEFINE in configure.ac because we are using config.h and this would render
the definition like this:
#define BINDIR "${exec_prefix}/bin"
instead of
#define BINDIR "/usr/bin"
So we instead define them in Makefile.am and add their definitions to
AM_CPPFLAGS, and quote them properly to make sure the value includes the
quotation marks when expanded in the C code.  I tested this with both an
rpmbuild and a regular developer type build.
Platforms tested: RHEL4/FC5
Flag Day: no
Doc impact: no

Note You need to log in before you can comment on or make changes to this bug.