Bug 215670 - rpmbuild --rebuild anjuta fails
Summary: rpmbuild --rebuild anjuta fails
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anjuta   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Paul F. Johnson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-15 04:13 UTC by John Ellson
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-24 16:20:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Ellson 2006-11-15 04:13:02 UTC
Description of problem:
rpmbuild --rebuild anjuta-2.0.2-10.fc7.src.rpm
fails on FC Rawhide i386 system

Version-Release number of selected component (if applicable):
anjuta-2.0.2-10.fc7.src.rpm

How reproducible:
100%

Steps to Reproduce:
1. rpmbuild --rebuild anjuta-2.0.2-10.fc7.src.rpm
2.
3.
  
Actual results:

...
gtk-doc: Compiling scanner
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag'
Compilation of scanner failed: 
make[4]: *** [scan-build.stamp] Error 1
make[4]: Leaving directory
`/home/ellson/rpmbuild/BUILD/anjuta-2.0.2/manuals/reference/libanjuta'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory
`/home/ellson/rpmbuild/BUILD/anjuta-2.0.2/manuals/reference'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/ellson/rpmbuild/BUILD/anjuta-2.0.2/manuals'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/ellson/rpmbuild/BUILD/anjuta-2.0.2'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.41477 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.41477 (%build)


Expected results:
no build errors

Additional info:

Comment 1 Paul F. Johnson 2006-11-15 07:13:08 UTC
Odd - it's quite happy on the FC buildsys. Please try the 2.0.2-11 version which
is out later today. I'll leave the bug open incase that also fails

Comment 2 John Ellson 2006-11-17 16:26:43 UTC
Same problem with anjuta-2.0.2-11.fc7.src.rpm



Comment 3 John Ellson 2006-11-17 17:20:29 UTC
This seems to fix the problem.    At least the build finishes for me now.

I can't explain the fix - it just looked odd.



--- anjuta.spec.orig    2006-11-17 11:29:39.000000000 -0500
+++ anjuta.spec 2006-11-17 11:29:45.000000000 -0500
@@ -58,7 +58,7 @@
 %configure --disable-static --disable-plugin-subversion --enable-nls
 %define libnoprefix %(echo %_libdir | sed 's,%_prefix/,,')
 sed -i -e 's!\(.*PACKAGE_PLUGIN_DIR@,.*\)lib\(/anjuta.*\)!\1%{libnoprefix}\2!g'
config.status ; ./config.status
-make LIBTOOL=%{_bindir}/libtool %{?_smp_mflags}
+make %{?_smp_mflags}
 
 %install
 rm -rf %{buildroot}


Comment 4 John Ellson 2006-11-17 17:39:17 UTC
BTW.  The reason I'm doing this is to build anjuta against an upcoming release
of graphviz.  I wanted to check that I hadn't broken anything.

I see the class-inheritance plugin, but I'm now sure how to drive it.  Can you
suggest a quick test that should result in a graph display?

Comment 5 John Ellson 2006-11-17 17:45:55 UTC
s/now/not/

Comment 6 Paul F. Johnson 2006-11-17 21:40:19 UTC
The libtool is needed otherwise rpmlint and rpmbuild (at least on my systems)
causes a fail. I can't explain what you're seeing!

I'll see if I can get a quick test together for the class-inheritance plugin

Comment 7 John Ellson 2006-11-18 15:43:27 UTC
Yes, libtool is required, but aren't you using a private version with
LIBTOOL=%{_bindir}/libtool ?    I think my change just changes it to use the
system version of libtool. 

Comment 8 Paul F. Johnson 2006-11-18 17:50:23 UTC
LIBTOOL=%{_bindir}/libtool

uses the version compiled by RedHat. If that is not defined in the make step,
the libtool supplied by the app is used

Comment 9 Paul F. Johnson 2006-12-24 16:20:29 UTC
I've rebuild anjuta quite a few times now and still fail to get the build to
break. I'll close the bug for now, but if you're getting the same problem, feel
free to reopen.


Note You need to log in before you can comment on or make changes to this bug.